Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I had 2 HDD, today I bought a new one, I would like to mount this HDD at boot, it's working, but the new HDD mounted under robu not root, why?

Content of the fstab:

UUID=8e492a04-c05d-4861-b996-a36ebbaf3d43 /media/WESYS_RAID    ext4   rw 0       0

UUID=12C81F25C81F071F  /media/WESYS_DATA  ntfs defaults,iocharset=utf8    0   0

/dev/mapper/WeSyS_LVM /media/WESYS_LVM ext4     rw 0    0

This is the rights.

drwxrwxrwx 1 root  root  4096 2012-04-05 11:51 WESYS_DATA
drwxr-xr-x 9 root  root  4096 2012-03-01 10:11 WESYS_LVM
drwx------ 3 robu  robu  4096 2012-04-10 12:33 WESYS_RAID
share|improve this question
What do you mean by 'mounted under robu'? Is 'robu' a contraction for something? Does it say 'robu' or '/robu' because those are not the same thing. Can you please include more details? – Jeff Welling Apr 10 '12 at 14:47
robu is the user, not a folder – Kicsi Mano Apr 10 '12 at 15:08
So, are you then trying to say that the new drive is mounting as /robu or /home/robu ? Or more likely, did you mean that the drive, after being mounted, is owned by the user 'robu' and not root? – Jeff Welling Apr 10 '12 at 15:20
yes exactly, sorry I'm not a native English speaker – Kicsi Mano Apr 10 '12 at 16:00
up vote 1 down vote accepted

You just need to change the options you have listed in /etc/fstab to something like defaults, user which is the same as rw,suid,dev,exec,auto,user,async. This should allow any user of the system to mount the device. The owner of the block device is what is listed in your second output. That can be changed by chown'ing the block device, but shouldn't be needed if you change the permissions of the folders under the root folder of that device.

Good Resources:

share|improve this answer
I can confirm my suspicion if you post the output of ls -l /dev/sd* /dev/mapper and add it to your question. – Huckle Apr 10 '12 at 16:40

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.