Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a Dell E6510 and after installing Ubuntu and connecting to a wireless network, my Wifi LED keeps blinking all the time, probably in response to traffic.

This is really annoying because it keeps drawing my attention away from the screen. Is there any way to turn this functionality off and just let the wifi light stay on all the time as long as it has a wifi connection?

Here is my lspci for the wifi:

Network controller: Intel Corporation Centrino Advanced-N 6200 (rev 35)
share|improve this question
    
I had the same problem with 10.04 on a D630, but it went away when I upgraded to 10.10. Which version of Ubuntu are you using? –  Roddie Nov 8 '10 at 22:23
    
Using Ubuntu 10.10, as you can see in the tag. –  Stefan Thyberg Nov 9 '10 at 15:30
    
IIRC this changed twice now, so I'd like to see an answer that contains an overview which module name to use with this fix to make it work in the currently supported Ubuntu desktop versions: 12.04 with the 3.2 kernel, 11.10/3.0, 11.04/2.6.38, and - if needed - 10.04/2.6.32. –  htorque Jul 28 '12 at 19:52
    
@htorque: answer added, please let me know your thoughts and if it's missing anything. –  izx Jul 30 '12 at 14:39

4 Answers 4

up vote 18 down vote accepted
  1. Open the terminal:

    Applications > Accessories > Terminal or Ctrl + Alt + t

  2. Enter the following in the terminal:

    gksudo gedit /etc/modprobe.d/wlan.conf
    
  3. Copy and paste the below line:

    options iwlcore led_mode=1
    
  4. Save the file.

  5. Restart the laptop.


This is a known bug: Bug #250211

share|improve this answer
    
Interesting! But the link does not work for me. –  OpenNingia Nov 8 '10 at 14:05
    
Fixed the typo. Now it will. :) –  Sid Nov 8 '10 at 14:24
    
this is the right answer. you may not see "wlan.conf" but you can edit a conf file that maps directly to the module name and add any switches that the card will accept - wondering about what switches? check driver source(i use this to disable hwcrypto for security tool/software ap purposes) –  hbdgaf Nov 8 '10 at 14:31
1  
@Stefan Thyberg: You shouldn't add it to this file because it deals with a different module/driver. If you use the above command, the file /etc/modprobe.d/wlan.conf is automatically created if it didn't exist. Maybe you should call it /etc/modprobe.d/intel-6200-iwlcore-disableblink.conf so you later know alone by the filename, what the change was all about. –  htorque Dec 16 '10 at 0:13
1  
Note that starting with kernel 2.6.39 it will be options iwlagn led_mode=1. –  htorque Mar 31 '11 at 12:09

Turning LED blinking off for Intel Wireless Cards (and some Atheros)

Note: based on an extensive study of all in-kernel wireless drivers (i.e. compat-wireless, only Intel cards and one Atheros chipset support module options to control LED behavior. Note that the actual LED control code in most drivers is fairly simple, so if you have basic familiarity with C, building kernel modules and reading the occasional datasheet, it's pretty easy to disable LED blinking for almost any wifi card with an open-source driver.

  • Press Alt+F2, and type gksudo gedit /etc/modprobe.d/iwled.conf (or open this file in your favorite editor)
  • Add the line options MODULE_NAME led_mode=1
    • MODULE_NAME is listed below for your Ubuntu version and your card model
    • Replace led_mode with the appropriate option if it is indicated, for the Intel 2200BG/2900ABG or Atheros cards
  • Save and exit the editor; reboot

1. Ubuntu 13.04 (Raring Ringtail) - kernel series 3.8

  • iwlwifi for Intel Centrino Wireless-N series 1xx, 1xxx, 2xx, 2xxx, 5xxx, 6xxx
  • iwlegacy for Intel Wireless series 3945 (tested), 4965
  • ipw2200 with led=0 for Intel Pro/Wireless 2200BG, 2915ABG
  • ath9k with blink=0 for Atheros wireless cards using the ath9k driver

2. Ubuntu 12.04 (Precise) - kernel series 3.2

  • iwlwifi for Intel Centrino Wireless-N series 1xx, 1xxx, 2xx, 2xxx, 5xxx, 6xxx
  • iwl-legacy for Intel Wireless series 3945, 4965
  • ipw2200 with led=0 for Intel Pro/Wireless 2200BG, 2915ABG
  • ath9k with blink=0 for Atheros wireless cards using the ath9k driver

3. Ubuntu 11.10 (Oneiric) - kernel series 3.0

  • iwlagn for Intel Centrino Wireless-N series 1xx, 1xxx, 2xx, 2xxx, 5xxx, 6xxx
  • iwl-legacy for Intel Wireless series 3945, 4965
  • ipw2200 with led=0 for Intel Pro/Wireless 2200BG, 2915ABG
  • ath9k with blink=0 for Atheros wireless cards using the ath9k driver

4. Ubuntu 11.04 (Lucid) - kernel series 2.6

  • iwlcore for Intel Centrino Wireless-N series 1xx, 1xxx, 2xx, 2xxx, 3945, 4965, 5xxx, 6xxx
  • ipw2200 with led=0 for Intel Pro/Wireless 2200BG, 2915ABG
  • ath9k with blink=0 for Atheros wireless cards using the ath9k driver

5. Ubuntu 10.04 (Lucid) - kernel series 2.6

  • The default for supported Intel Centrino cards in 10.04 is to simply keep the LED on if wireless is on (and off otherwise), so this "mod" should not be needed (thanks htorque!)
  • ipw2200 with led=0 for Intel Pro/Wireless 2200BG, 2915ABG
  • ath9k with blink=0 for Atheros wireless cards using the ath9k driver
share|improve this answer
    
@htorque: thanks, edited answer to reflect that. –  izx Jul 30 '12 at 19:40
    
Works fine on Ubuntu 13.10 –  Atropo Jan 18 at 9:48
    
Using options iwlegacy led_mode=1 worked for me on Ubuntu 14.04 with a Compaq nx7300 –  nbolton Jul 18 at 10:08

I believe that 'problem' is not solvable by Ubuntu itself. It is quite a standard for the activity LEDs to blink on traffic ( the HD LED should do the same ). They work directly at the hardware level, bypassing the operative system.

My advice is to use a tiny piece of tape to cover the LED :)

share|improve this answer
1  
That is not true, since it does not do this for my Windows installation. –  Stefan Thyberg Nov 8 '10 at 12:28
    
My bad:) It is true on my laptop, I should've investigated more. iamsid solution seems interesting. –  OpenNingia Nov 8 '10 at 14:05
1  
that's actually how it's supposed to work on most systems though. –  RolandiXor Nov 8 '10 at 14:06

In my E6510 the file was called /etc/modprobe.d/intel-5300-iwlagn-disable11n.conf

I am using Ubuntu 11.04 and "modinfo iwlcore" shows that there is a parameter led_mode, so this works fine.

share|improve this answer
    
See the comments on the accepted answer for why you shouldn't use that particular file. It does work though, it's just not quite the right place for it. –  Stefan Thyberg Feb 9 '11 at 12:15

protected by Community May 23 '11 at 15:03

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.