Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Google has an Easter egg that draws 3D graph but when I tried it out on chrome it complained about no WebGL support. I've also tested it on Firefox whose WebGL support was enabled but ended up with the same problem. Thus, I suspect it's an issue of my GPU. Some googling led me to chrome://gpu and here's what I got

Graphics Feature Status

  • Canvas: Software only, hardware acceleration unavailable
  • HTML Rendering: Software only, hardware acceleration unavailable
  • 3D CSS: Unavailable. Hardware acceleration unavailable
  • WebGL: Unavailable. Hardware acceleration unavailable
  • WebGL multisampling: Unavailable. Hardware acceleration unavailable

Problems Detected

  • GPU process was unable to boot. Access to GPU disallowed.
  • GL driver is software rendered. Accelerated compositing is disabled.: 59302
  • Mesa drivers in linux older than 7.11 are assumed to be buggy.
  • Accelerated 2d canvas is unstable in Linux at the moment.

Version Information

  • Data exported Tue Apr 10 2012 18:35:57 GMT+0800 (CST)
  • Chrome version 18.0.1025.151 (Official Build 130497)
  • Operating system Linux 3.0.0-0300-generic
  • Software rendering list version 1.27
  • ANGLE revision 988
  • 2D graphics backend Skia

I wonder what each of the problem implies and How I may properly deal with it? I'm using Ubuntu 11.04

share|improve this question

3 Answers 3

Its because your GPU (or the driver being )is not supported for WebGL. Its browser blacklisted.

However you can force enable your GPU for WebGL.

Warning: Do this at your own risk. It can harm your hardware. There are usually good reasons (like some critical driver bug) why features are blocked.

To launch chrome ignoring the black list, run following after pressing Alt + F2 OR in terminal

google-chrome --enable-webgl --ignore-gpu-blacklist

Configuring firefox:

  • To force-enable WebGL, go to about:config and set webgl.force-enabled=true.

  • To force-enable WebGL anti-aliasing, go to about:config and set webgl.msaa-force=true.

  • To force-enable Layers Acceleration, go to about:config and set layers.acceleration.force-enabled=true.

More reads on firefox blacklisting.

share|improve this answer
1  
thanks, tried both but no work –  manuzhang Apr 10 '12 at 11:53

It's because your GPU (or the driver being used)is not supported for WebGL. It's browser blacklisted. However, you can force enable your GPU for WebGL.

In Google's Chrome:

chrome://flags/

Enable. Override software rendering list.

This can have unstable results. As "Accelerated 2d canvas is unstable in Linux at the moment and Stage3D is not supported on Linux." I found it best to leave it disabled and just update your graphic driver. With the "preferred" v.280 NVIDIA driver, Chrome says it can't support 3D, but it worked fine being forced. Updating to the version current-updates (v.295.2 as of today. v.304.51 is the official release), enables everything that works.

Good luck.

share|improve this answer

I just followed the instructions in the article below, and it worked for me.

Chrome on Linux with WebGL and all the hardware acceleration stuff

It suggests you to enabled/disable the following flags in chrome://flags:

  • [ON] Override software rendering list (probably the most important one if your hardware is blacklisted)
  • [ON] GPU compositing on all pages
  • [ON] Threaded compositing
  • [OFF] Disable accelerated 2D canvas
  • [OFF] Disable deferred 2D canvas
  • [OFF] Disable accelerated CSS animations
  • [ON] GPU Accelerated SVG Filters
  • [OFF] Disable GPU VSync
  • [OFF] Disable WebGL
  • [ON] Smooth Scrolling
  • [ON] Enable CSS Shaders

These two other options are suggested too but marked as "not related to graphics"; but they may be useful in certain cases.

  • [ON] Enable Encrypted Media Extensions on elements
  • [ON] Web Audio Input

Now I couldn't find all of those flags as I'm currently running Google Chrome version 30 but the experiments leading to the article were done on Google Chrome version 23, but it worked just fine and now I have all the Graphic Features (listed in chrome://gpu) enabled and working.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.