Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Error starting job: Failed to execute child process "cryptsetup" (No such file or directory)

After a system reinstall (I'm on Ubuntu 10.04), I'm having trouble accessing my second Hard Disk, when I try to mount the encrypted volume I am prompted to enter the password, when I do I receive the above error.

Any thoughts?

share|improve this question
up vote 4 down vote accepted

Firstly open the terminal and type

sudo apt-get install cryptsetup

Now retry mounting your encrypted drive. Hope that helps.

share|improve this answer
I tried that, just get "E: Couldn't find package cryptswap " do you know what ppa it's in? – Ashley Apr 10 '12 at 12:52
I think its 'cryptsetup' instead of 'cryptswap'. Secondly you may try using : "sudo apt-get update" And then retry the above solution. – YetAnotherG33k Apr 10 '12 at 13:07
Could you please let me know what worked? Were you making a mistake in the name as 'cryptswap' or did the update help? – YetAnotherG33k Apr 10 '12 at 13:40
As a side-note, in order to tell what package a file is provided in, you can use apt-file. – Jeff Welling Apr 10 '12 at 14:57

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.