Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have Intel Core 2 Duo processor. In the BIOS I've enabled the Processor support for VT - Virtualization Technology. But when I ran the following command no output is shown

grep --color vmx /proc/cpuinfo
egrep '(vmx|svm)' /proc/cpuinfo

How to fix this problem? I want Virtualization support to run certain Operating systems inside the VirtualBox Virtual machines.

I'm running Ubuntu 12.04 Beta 2. Linux 3.2-pae flavour

Any suggestions or solutions?

My CPU capabilities are shown by lshw like this

boot fpu fpu_exception wp vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov 

pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe nx x86-64 constant_tsc 

arch_perfmon pebs bts aperfmperf pni dtes64 monitor ds_cpl est tm2 ssse3 cx16 xtpr 

pdcm sse4_1 xsave lahf_lm cpufreq

I see vme..But not vmx...What is the difference between vme and vmx capabilities?

share|improve this question
The vme flag is "Virtual-8086 Mode Enhancement", so not what you're looking for. Also, have you verified that your processor supports VT-x at – James Henstridge Apr 10 '12 at 6:40
@JamesHenstridge: Mine's Intel Core 2 Duo E7400....But the site shows three more variants of E7400 which I can't figure out right now - SLB9Y, SLBQ8, SLBW3 – Suchith JN Apr 10 '12 at 11:19
In my BIOS I find an option Intel VT for Directed I/O(VT-d) whose description is like this - Enables or disables processor support for Virtualization. In BIOS it shows Processor Type: Intel Core 2 Duo CPU E7400 @ 2.80Ghz Intel 64 architecture Motherboard: DG41RQ BIOS version: RQG4110H.86A.0009.2009.0108.1005 I'm running 32-bit Ubuntu 12.04 – Suchith JN Apr 10 '12 at 11:37
Per the FAQ, questions about 12.04 are currently off-topic. Do you experience this problem in 11.10? – zpletan Apr 10 '12 at 15:12
Can you add this information into your question so it's not buried in the comments? Thanks. @zpletan Not all 12.04 questions are always offtopic, see – Jorge Castro Apr 10 '12 at 15:19

If you have made sure virtualisation is enabled in the BIOS and it still doesn't show up in the flags shown in /proc/cpuinfo, then it seems likely that your processor doesn't support virtualisation.

Only one of the three processors sharing the Core 2 Duo E7400 model number is listed as supporting VT-x, so chances are that you have one of the other versions. The family, model and stepping values listed in /proc/cpuinfo should uniquely identify the processor, but I don't know they map to Intel's spec codes. You could always check the top of the CPU, but that would require removing and reattaching the CPU fan.

It is possible that your BIOS shows the virtualisation disable option unconditionally, so it might not be evidence that your CPU supports VT-x.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.