Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed Ubuntu 11.10 recently. After the first bootup the computer freezes so I have to force-quit my computer.

Then I turned on my computer after that. I tried connecting to the internet. My (and my neighbor's) wireless networks shown up, but no matter how many times I tried, I can't connect to my home network. I checked the password and the other laptop's internet works (a MacBookPro). It was a wireless network.

What's weird is that the Wireless network worked when I was installing ubuntu

How can I connect to the internet now? I don't have a wired network.

Please Help! Any help will be appreciated

Specs: ASUS F81Se, Windows 7 Dual-boot, Card: Atheros AR928X, 4GB RAM

share|improve this question
1  
start with adding the lsmod | grep ath and lspci output to the question –  hbdgaf Apr 10 '12 at 0:54

4 Answers 4

well few days back i have the same problem may be these two images might help you just do what have been done in the pics

enter image description here

share|improve this answer
    
Thanks for the answer but it didn't work:( and where's the second image? Help! –  Emerson Hsieh Apr 11 '12 at 0:32
    
OK first go to "edit connections" then to "wireless" from there choose your internet connection name you are using and press "edit" button. after that a new window will appear from there choose "IPv4 seetings" tab ad set 'METHOD" to " automatic(DHCP) addresses only" and set "DNS=8.8.8.8,8.8.4.4" and after that do it like above window save it and reboot that would work –  remeses Apr 13 '12 at 10:42

Try this command: CTRL+ALT+T to open Terminal. At Terminal type the following accordingly or copy and paste.

  1. rmmod iwlagn

  2. modprobe iwlwifi bt_coex_active=0

share|improve this answer
    
ERROR: Module iwlagn does not exist in /proc/modules and FATAL: Module iwlwifi not found. What's the problem on my computer here????? Help!!!!! –  Emerson Hsieh Apr 11 '12 at 2:15
    
it is 'rmmod' not rmod. Copy and paste each line: 1.rmmod iwlagn 2.modprobe iwlagn bt_coex_active=0 .I have replace iwlwifi with iwlagn. Do that and report back with your information. –  all4naija Apr 11 '12 at 2:24
    
Same: ERROR: Module iwlagn does not exist in /proc/modules The other one: FATAL: Error inserting iwlagn (/lib/modules/3.0.0-17-generic-pae/kernel/drivers/net/wireless/iwlwifi/iwlagn.ko‌​): Operation not found. Sorry for asking so many questions I am just a noob on internets because this never happened to me before –  Emerson Hsieh Apr 11 '12 at 2:38

This happened to me both times I installed Ubuntu on my netbook. I knew the password was correct but it just would not connect to my network. After I did the following it has worked fine.

Try this, click on the wifi icon at the top. Then click on Edit Connections. Select the wifi tab. Click and highlight your network in the list and then click the delete button to delete the network from the list. Close the window the try connecting to your network again.

share|improve this answer
    
WHat is wrong with my computer!!!! Thanks for the answer I know it works some times, but I tried for about 10 times but still no internet!!!!! –  Emerson Hsieh Apr 11 '12 at 2:37
    
Try xt reset. Disconnect your charger, remove your battery and hold the power button down for 10 seconds or more. After that, reconnect those accessories back and start your system. Upon booting tap the F2 key to enter BIOS setup and select default, Save and continue. When you are done, check if your Wlan is put on by depressing Fn+F2 simultaneously. –  all4naija Apr 12 '12 at 5:42

Now, try this at terminal:

Step I:

gksu gedit /etc/modprobe.d/intel_11n_disable.conf .Enter your system password and click okay.

Step II :

copy and paste this into the editor iwlwifi 11n_disable=1 and click save.

Step III:

sudo update-initramfs -u and restart your system.

share|improve this answer
    
Um, thanks but... still no internet. –  Emerson Hsieh Apr 11 '12 at 3:27
    
I would say this is a bug.Save you important files and reinstall Ubuntu from your live CD. I hope that helps. –  all4naija Apr 11 '12 at 3:30
    
Thanks! But how do I reinstall Ubuntu? PS: I don't have any programs or files on it yet because I don't have internet –  Emerson Hsieh Apr 11 '12 at 3:33
1  
With the CD you used in doing the installation in the first time.Insert it into your DVD/CD ROM and direct your system to boot from it. Then chose erase and install Ubuntu and continue with the installation. Probably this would be the last resort in finding solution to this connection bug. –  all4naija Apr 11 '12 at 3:41
    
In the other sense, if you could post here you could as well visit the Ubuntu website at " ubuntu.com/download/ubuntu/download " to download the ISO image file and burn it to CD/DVD to do your installation –  all4naija Apr 11 '12 at 3:52

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.