Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

The following formats do not have an icon in Nautilus:

.odt .odb

And, some of my older documents are missing their thumbnails, all of which are either .odt or .odp.

I just purged and reinstalled LibreOffice today...could this be the reason why?

Edit: Sorry about my vagueness

I am on Ubuntu 11.10, using LibreOffice 3.4 340m1(Build:402) that comes by default in the repos.

Here's a screenshot of what I see for these formats.

share|improve this question
Can you give more information? what you see? wich ubuntu version and where you have install libreoffice (from repo or any ppa)? In my computer I see this for example: – peppe84 Apr 9 '12 at 22:22
Of course...I tend to be vague sometimes, sorry about that. I'll add it to my original post as an edit. – Ryan McClure Apr 9 '12 at 22:24
I have found look around the solution: Seem work for that user – peppe84 Apr 9 '12 at 22:42
My .local/share/applications folder doesn't have anything tied to LibreOffice. :( – Ryan McClure Apr 10 '12 at 0:59
up vote 3 down vote accepted

To have LibreOffice documents in Nautilus while using Ubuntu 11.10 you need to install an extension to it since those are not supported by default.

The only one I know of is ooo-thumbnailer from this PPA, it can be installed using these commands in a terminal:

sudo apt-add-repository ppa:flimm/ooo-thumbnailer
sudo apt-get update
sudo apt-get install ooo-thumbnailer

When its done installing you should need to log off or restart Nautilus with nautilus -q.

It should be safe to use this PPA but you should always remember there are no warranties using PPAs.

For more information on what are PPAs and risks involved in using one please have a look at the following posts:

share|improve this answer
I installed ooo-thumbnailer and restarted my computer. Still no icons. Thank you for your help, though. Do you think maybe some files are missing from my LO install? – Ryan McClure Apr 9 '12 at 22:29
@RyanMcClure Newest release (0.5) works fine for me on 12.04.2 LTS and with LO 3.6.5 installed. Did you install LO manually or from the repos/a PPA? – Glutanimate Mar 6 '13 at 17:20
Another option is the libgsf-bin package. It works for me in 14.04! – Bruno Nova Jan 22 '15 at 19:06

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.