Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am facing a strange problem with my laptop, I have ubuntu 12.04 installed with xfce4 as the desktop. Whenever I open any new program like firefox by typing firefox in run dialog window, it opens a terminal in the background.

please refer this screenshot.

enter image description here

Has anybody else faced this problem earlier? I was not able to find a similar kind of issue anywhere else. By the way,im using xfce4.8 as desktop? is this issue with xfce desktop?

share|improve this question
    
no im not running firefox &(background), whenever i open a run dialog using alt+f2 and execute any program, a new terminal window is opened as seen in the screenshot. –  rao_555 Apr 14 '12 at 23:48
    
Also, if I close the terminal window, the program(firefox) will get closed. –  rao_555 Apr 14 '12 at 23:49
    
i am using xfwm4 –  rao_555 Apr 15 '12 at 0:02
    
I installed through 12.04 mainline and added the xubutnu-desktop. I cannot replicate this issue. When I launch with firefox & through alt-f2 I do get a www.&.com couldn't be resolved error. –  hbdgaf Apr 15 '12 at 0:29
add comment

1 Answer

up vote 4 down vote accepted
+100

This happens when you check the "Run in terminal" box when hitting alt+f2.
The change is persistent meaning that if you check it by accident, or use it on purpose the setting will remain next time you bring up the run dialog.

The purpose for this is to make the program run from a terminal so you can monitor output or possible errors put out by the program, also closing the terminal running the program will also close the program.

To fix just uncheck that box, shown here-

enter image description here

If this action is still hapening but the check box appears not to be checked try these steps-

  1. Try checking the run in terminal box
  2. Run a program
  3. Bring run in terminal back up and try to uncheck it again
  4. Run a program

This might be the results of one of two problems

Either the theme for the check is not working or this bug may be relevant - http://mail.xfce.org/pipermail/xfce-bugs/2007-January/003075.html

share|improve this answer
    
magically it worked!!!! seems that is the issue , the run in terminal checkbox value is cached and is not refreshed properly. thanks @matthew –  rao_555 Apr 15 '12 at 22:02
    
awarding bounty for finding that issue in xfce mailing list :) –  rao_555 Apr 15 '12 at 22:03
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.