Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After unsuccessful upgrade of Gnome3 packages in new Precise Pangolin 64-bit environment I get this error at installing gnome-shell-extensions-user-theme package:

The following packages have unmet dependencies:
 gnome-shell-extensions : Conflicts: gnome-shell-extensions-user-theme
 but 3.2.0-2~webupd8~oneiric is to be installed
E: Unable to correct problems, you have held broken packages.

I tried to remove by running sudo apt-get purge gnome-shell-extensions-user-theme but get this:

Package gnome-shell-extensions-user-theme is not installed, so not removed

My Gnome Classic profile works well but Gnome3 session can't run.

How to resolve this error?

share|improve this question
    
I highly suggest you file a bug report. FWIW , the gnome-shell extensions seem to work best using the web interface extensions.gnome.org –  bodhi.zazen Apr 9 '12 at 17:23
    
It seems like you are using a PPA to get that package, so it could be a PPA-specific bug. –  Alexandre Apr 9 '12 at 17:26
    
no, people, it's no bug ... held broken packages I get with forced system shutdown when I was upgrade packages ... (( sorry forget string E: Unable to correct problems, you have held broken packages. –  swift Apr 9 '12 at 17:54

3 Answers 3

up vote 1 down vote accepted

The package gnome-shell-extensions-user-theme from WebUpd8 team PPA as broken dependencies better use https://extensions.gnome.org for extensions.

But first you've got to get rid from the old files.

sudo rm -r /usr/share/gnome-shell/extensions/*
rm -r ~/.local/share/gnome-shell/extensions/*

This will clear all gnome-shell extensions.
Next restart gnome-shell and you're ready to go.

share|improve this answer

Solved trouble, but after full reinstall through backup with new precise beta 2.
To be correct need mention of two repositories:
ppa:gnome3-team/gnome3 and ppa:ricotz/testing

WARNING thats can be fatal testing on 11.10 and make system unstable on both 12.04 betas.

Though webupd8 also have this package but I was spotted by unsuccessful experience with full loosing of shell view, with just tty available.

It is impossible to negate a benefit of webupd8, just some remembering thats can be useful to care about dependencies :)

share|improve this answer

If your using precise then you are on G-S version 3.4 and the extensions you are trying to install are for Gnome Shell 3.2 also your using the oneric version from the webupd8 ppa and need to change to precise.

Just open up synaptic and open settings repositories and scroll to the webupd8 ppa and edit the oneiric to precise and you should be fine!

share|improve this answer
    
however, package gnome-shell-extensions-user-theme in WebUpd8 Precise PPA existing in version named 3.2.0-2~webupd8~oneiric ... my software sources all tuned for precise ... –  swift Apr 9 '12 at 20:11
    
you will need to uninstall the 3.2 extensions and install the offical ones! there are some 3.4 packages in the webupd8 ppa like weather media-player gpaste etc :-) –  bmbaker Apr 10 '12 at 9:11
    
sorry earlier my turn out to cold so now I see your answer also useful despite some of it certainty ... so ok +1. –  swift Jun 21 at 19:18

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.