Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

whenever try to mount ntfs partition it says

Error mounting: mount exited with exit code 1: helper failed with: Unprivileged user can not mount NTFS block devices using the external FUSE library. Either mount the volume as root, or rebuild NTFS-3G with integrated FUSE support and make it setuid root. Please see more information at http://tuxera.com/community/ntfs-3g-faq/#unprivileged I tried this answer but it wont work

enter image description here

my etc/fstab file

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc                                       /proc        proc  nodev,noexec,nosuid              0  0  
# / was on /dev/sda7 during installation
UUID=ed9e007f-da86-4436-993a-8670ebf45939  /            ext4  errors=remount-ro                0  1  
# swap was on /dev/sda6 during installation
UUID=956e15af-d650-42ac-a5f6-89955abaacde  none         swap  sw                               0  0  
/dev/sda1                                  /media/sda1  ntfs  nls=iso8859-1,ro,umask=000,user  0  0  
share|improve this question
    
If you're running out of the box Ubuntu, I've never seen this happen. –  hbdgaf Apr 9 '12 at 4:39
    
Can u check my updated answer and verify it again –  mac Apr 9 '12 at 7:14
add comment

5 Answers 5

up vote 1 down vote accepted

Can you check the contents of /etc/fstab file ?

As its a very important file, backup it first.

sudo cp /etc/fstab /etc/fstab.bak

Instead of doing it on command line, do it using GUI tools please check this

http://www.webupd8.org/2011/11/how-to-mount-partitions-automatically.html

Note: Its a very important file. Please double check before doing any changes.

Update : Looks like you are not able to change settings with pysdm due to some bug in it - "No matter what I do with pysdm - Mount file system in read-only mode, still remains checked."

This can be fixed by manually editing /etc/fstab file . Changed

/dev/sda1                                  /media/sda1  ntfs  nls=iso8859-1,ro,umask=000,user  0  0  

to

/dev/sda1                                  /media/sda1  ntfs  nls=iso8859-1,rw,umask=000,user  0  0  

or even

/dev/sda1                                  /media/sda1  ntfs  nls=iso8859-1,umask=000,user  0  0  

and rebooted the system.

share|improve this answer
    
question updated –  Tachyons Apr 9 '12 at 5:57
    
answer updated as well. –  mac Apr 9 '12 at 6:01
    
lol pysdm is the reason for this error –  Tachyons Apr 9 '12 at 6:07
    
pysdm wont work :( –  Tachyons Apr 9 '12 at 6:17
    
Have you done these settings - make sure the "Mount file system in read-only mode" is unchecked (this is automatically checked for NTFS partitions), - check the "Allow any user to mount the file system" box, - check the "Allow a user to mount and unmount the filesystem" box, –  mac Apr 9 '12 at 6:18
show 3 more comments

My NTFS mounts have always been fine until I try to get them to mount at boot - then its one drama after another. I had the same prob with pysdm as the OP. This suggestion from mac (above) appears to have fixed it -

/dev/sda1                                  /media/sda1  ntfs  nls=iso8859-1,rw,umask=000,user

I commented out the old entry in fstab generated by pysdm though, it looks like this -

/dev/sda5                                  /media/data       ntfs  
# nls=iso8859-1,rw,group=users,users,umask=000,gid=users,user,owner,uid=fnord  0  0  
nls=iso8859-1,rw,umask=000,user  0  0

It works on reboot, BUT - there is a mount error when it's booting, with a "ignore or repair". I ignore, it boots and everything is perfect.

EDIT - Well, that was enthusiastic moderation. Unaware hardware shop items can cause flagging... My question again - I am hesitant to do other changes to fstab. I was wondering if my change shown above is the cause of the bootup mount error warning?

share|improve this answer
add comment

Hi I got a similar problem.

In my case (Ubuntu 12.04, using gparted and pysdm) I got a loading problem at start up, sdb2 was not able to mount at media/partitionName , where partitionName was the folder I set up with pysdm. In my case I was able to use and automount at start up before, and suddenly this problem started.

Then I was not able to mount it manually either, and I got the message Unable to mount.... (see figure in the first question above). I found that the problem was generated by windows hibernation. After I restarted from windows and turn it off the whole problem disappeared. I was able to see that the problem was hibernation when I tried to mount by hand:

sudo mount -t /dev/sdb2 /media/partitonName

Hope this could help some one.

share|improve this answer
add comment

There's a good answer to the NTFS-3g problem here.

http://ubuntuforums.org/showthread.php?t=1661757

share|improve this answer
2  
Can you include the relevant parts of the solution here? Thanks. –  belacqua Nov 27 '12 at 19:19
add comment

I had the same problem caused by pysdm.

I just deleted entries made by pysdm in fstab, as I didn't want NTFS partition to automount, I just wanted to be able to mount it by clicking in Nautilus. It worked.

share|improve this answer
add comment

protected by Braiam Feb 26 at 13:31

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.