Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am running Precise beta 2 on a Dell Latitude E6410 with nVidia graphics.

I have set up the power management to turn the screen off after 10 mins of inactivity. Instead of it turning off, it simply goes blank (it's black, but the screen is still on). I'm not sure why this is happening.

xset -q shows:

Screen Saver:
  prefer blanking:  yes    allow exposures:  yes
  timeout:  0    cycle:  0
Colors:
  default colormap:  0x20    BlackPixel:  0    WhitePixel:  16777215
Font Path:
  /usr/share/fonts/X11/misc,/usr/share/fonts/X11/Type1,built-ins
DPMS (Energy Star):
  Standby: 0    Suspend: 0    Off: 0
  DPMS is Enabled
  Monitor is On

I do not have a screensaver set up (in fact I don't even have the option under System Settings).

share|improve this question
    
I think this might have something to do with gnome-screensaver. Although I can't seem to find anywhere to configure it. –  NOP Apr 10 '12 at 0:30
add comment

3 Answers

I had the same problem.
I solved the issue by installing the new Nvidia drivers (version 304.51).
I used the x-swat PPA:

    sudo apt-add-repository ppa:ubuntu-x-swat/x-updates
    sudo apt-get update
    sudo apt-get install nvidia-current

I hope I helped someone...

share|improve this answer
add comment

Reading your xset configuration, I'd say it isn't xorg which sets your screen blank. I guess it is gnome screensaver which blanks the screen after 10minutes (idle-session...). Your dpms settings shows that screen will never power off automatically.

If you want to force a switch off after 10 min of inactivity, you should type : xset dpms 0 0 600

You may also disable the gnome screensaver (useless as the screen will swith off after 10min): gsettings set org.gnome.desktop.screensaver idle-activation-enabled false

If you want a screensaver before switching off the screen after 5 minutes, you may enable the xorg screensaver : xset s 300

Regards,

share|improve this answer
add comment

Hopefully you have solved the problem now. However, just for anyone else who may be experiencing this problem just re-setting the xset dpms energy star settings will do the trick...usually! Just open a terminal Ctrl + Alt + T and type:

xset +dpms (no sudo needed) then press Enter.

That instruction turns on the power management control. Sometimes the xset -q command in a terminal shows the power management 'dpms enabled' as with the screen shot shown at the top of this thread. It doesn't in fact definitely mean it is switched on. In fact I've discovered it's often a completely false reading and the PMS is 'Off'.

Once you have entered the command xset +dpms as above, go to 'System Settings' and 'Brightness & Lock' control. There you can adjust the time before the screen powers down. It will work for mostly everyone with this problem I've found.

IanW -Superuser Ubuntu 12.04 LTS

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.