Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I installed Ubuntu 11.10 today. After the reboot I selected Ubuntu and it kept hanging at the purple screen. No error message was shown.

The liveCD went fine and the installation was successful. I tried recovery mode but it Still didn't work

Please Help! Any help will be appreciated

Specs: ASUS F81Se, Windows 7 Home Premium, ATI RADEON 512mb Graphics card, 4gb ram

share|improve this question
up vote 9 down vote accepted

Well AMD Radeon graphics cards (especially the recent ones) are difficult to use with Linux. It happens exactly the same with my AMD Radeon HD6850, until I install the FGLRX proprietary driver package.

To install it, you must go into the Recovery Mode. To do that, hold SHIFT at startup so the GRUB menu is displayed, choose Ubuntu Recovery Mode after that. Choose to mount the disk as read/write, then drop to the root shell with networking (this is very important).

Then do the following commands once you're dropped to the root shell:

sudo apt-get update
sudo apt-get upgrade   
sudo apt-get install fglrx    
sudo aticonfig --initial
sudo reboot

If everything worked, you should be fine and see the desktop after this.

share|improve this answer
It booted alright, but I can't connect to the internet, so how can I install the Drivers? Help! – Emerson Hsieh Apr 9 '12 at 1:22
Go to BIOS > Security> I / O interface Security> "New interface card". Set it to Locked. Now this is a permanent fix – Emerson Hsieh May 1 '12 at 0:30

There is a Way Easier Fix...

Just enter "e" after GRUB loads

Then delete $linuxgfxmode from like the 3rd or 4th line down and replace with nomodeset

Winner almost everytime on 11.10 and 12.xx apparently.

share|improve this answer
I changed it into nolapic and it worked a long time ago – Emerson Hsieh Apr 15 '12 at 5:00
That worked for me too. Just to clarify, the full line in my version is: "gfxmode $linuxgfxmode". I replaced it with "gfxmode nomodeset" – Sridhar-Sarnobat Mar 16 '13 at 23:35
Could somebody explain, what this change means? – Sanjeev Kumar Dangi Sep 24 '13 at 13:33

I have tried all of the above and none of them worked. I was able to fix it by pressing Shift and F3 at the purple screen. This will bring you to the command prompt. Log in and type:

sudo service lightdm start

If this worked you should be brought the login page. You're Welcome.

share|improve this answer

I had the same problem ,but all of the above tips didn't work. Then I realized the graphics driver was in switchable graphics mode.

When i changed the graphics driver to UMA mode in the BIOS, it worked.

share|improve this answer

ATI RADEON 512mb Graphics card, (ati) xorg problem.

I have a hd 5670 - I did the following:

  • go to recovery mode
  • sudo rm /etc/X11/xorg.conf
  • reboot.

If instead it works for you, do the following - backup of your xorg with:

  • sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf.bak
  • install fglrx drivers from amd website
share|improve this answer
Downmodded to -2? Why? Please leave a comment why something is a bad answer... – Stijn de Witt Aug 3 '12 at 21:05

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.