Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am making a custom session (using .xsession) and I want to use compiz. When I use the compiz or compiz --replace command in the .xsession and also using "recovery console" option, it seems to not load any plugins. After starting compiz, I start ccsm and no plugins are loaded.

Back when I used arch there were a bunch of arguments for compiz and I would use 3 or so, and one of them told compiz to load settings from my config at launch. Here is the compiz --help from Ubuntu 12.04:

Usage: compiz [OPTIONS] [PLUGINS ...]
Options:
  --replace             Replace any existing window managers
  --display DISPLAY     Connect to X display DISPLAY (instead of $DISPLAY)
  --sm-disable          Disable session management
  --sm-client-id ID     Session management client ID
  --keep-desktop-hints  Retain existing desktop hints
  --sync                Make all X calls synchronous
  --debug               Enable debug mode
  --version             Show the program version
  --help                Show this summary

Those are also the only options under man compiz

Here's the thing: when I run compiz --replace under the unity session, plugins load alright and all that good stuff. When I run that under my session, compiz loads nothing.

Info that may help:

  • I have tried compiz --replace gconf
  • I always have gnome-settings-daemon running
  • I am using Ubuntu 12.04 (beta release)
share|improve this question
    
Have you gone to CCSM and enabled the plugins? –  TenorB May 14 '12 at 1:40

2 Answers 2

I had to modify compiz config to use gconf as configuration backend when upgrading 11.10 -> 12.04.

/etc/compizconfig/config:

[general]
#backend = ini
backend = gconf
integration = true
plugin_list_autosort = true

After this modification, running compiz --replace in .xsession resulted behavior I was used to in 11.10.

share|improve this answer

Go to "startup applications" and create a application launcher.

Name = Compiz
Command = compiz --replace
Comment = start compiz

enter image description here

share|improve this answer
    
How does this help me? –  Relish Apr 8 '12 at 19:32
    
once the OS loads the startup application kicks in and loads compiz. The same as going to a terminal and typing compiz --replace give it a try....I use it for that exact reason –  Ringtail Apr 8 '12 at 19:33
    
No, whenever i do that it doesn't load any plugins. I AM NOT REPLACING A RUNNING INSTANCE OF COMPIZ OR ANY OTHER WINDOW MANAGER! I need compiz to LOAD PLUGINS! –  Relish Apr 8 '12 at 20:00
    
you know that "mutter" is the default composer so running compiz in 12.04 might not work –  Ringtail Apr 8 '12 at 20:04
2  
Unity uses compiz.... –  Relish Apr 8 '12 at 20:16

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.