Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm running an HTPC (xbmc) without a keyboard/mouse attached, running oneiric. After some indeterminate amount of time, sometime between 1 and 12 hours, the display goes to sleep. The computer itself is not sleeping, I can still SSH to it from another computer. The remote will not wake the display. The IR receiver is working, as irw will show me the remote key presses. The only way to get my display back is to restart the display manager, lightdm in this case.

Does anybody know a way to keep the display from going to sleep? I don't really need any power management at all considering that it connects to my TV and when I want my display to go to sleep, I turn off my TV.

share|improve this question
add comment

1 Answer

It MIGHT be screensaver related. If you run XBMC from Gnome (or similar), you can try (for 11.10):

gconftool-2 -s /apps/gnome-screensaver/idle_activation_enabled --type=bool false

Or for 12.04:

gsettings set org.gnome.desktop.screensaver idle-activation-enabled false

If you are running XBMC in its own session (you log in to xbmc from lightdm) you might be experiencing the same problem as me: How do I disable the screen saver in 12.04 system wide?

share|improve this answer
    
Yeah, lightdm launches it directly. I've tried all of these solutions before though, so I'm back to the drawing board. Thanks anyway. –  Eugene May 11 '12 at 17:35
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.