Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm using Kubuntu 12.04 (64bit). The Ubuntu repos contain gpt fdisk 8.1 which is not the latest. The latest version is 8.4 and it contains some bug fixes I want to have.

I downloaded the latest deb package from here: http://download.opensuse.org/repositories/home:/srs5694/xUbuntu_11.10/amd64/gptfdisk_0.8.4-1_amd64.deb

When I tried to install it initially, I got an error that dependencies could not be satisfied. So I installed the version from the repos first, then tried to install the latest version over that. Now I get the error below.

# dpkg -i gptfdisk_0.8.4-1_amd64.deb 
Selecting previously unselected package gptfdisk.
(Reading database ... 90031 files and directories currently installed.)
Unpacking gptfdisk (from gptfdisk_0.8.4-1_amd64.deb) ...
dpkg: error processing gptfdisk_0.8.4-1_amd64.deb (--install):
 trying to overwrite '/usr/share/man/man8/cgdisk.8.gz', which is also in package gdisk 0.8.1-1build1
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Processing triggers for man-db ...
Errors were encountered while processing:
 gptfdisk_0.8.4-1_amd64.deb

How can I install 8.4 of gpt fdisk?

share|improve this question
    
I had the same problem, yesterday. The problem is that the latest gptfdisk has a dependency on a library (libicu44) that does not exist in 12.04. My guess is that the library has been superceded. –  Tim Apr 8 '12 at 23:15

2 Answers 2

libicu44, I downloaded this one. It installed fine.

http://mirror.pnl.gov/ubuntu//pool/main/i/icu/libicu44_4.4.2-2ubuntu0.11.10.1_amd64.deb

share|improve this answer
    
that's not a deb package to install gpt fdisk. I think you answered the wrong question. –  MountainX Apr 17 '12 at 13:37
    
+1 - thx - that's exactly what I needed –  kfmfe04 Nov 11 '12 at 9:05
up vote 2 down vote accepted

It is available here now:

https://launchpad.net/ubuntu/+source/gdisk/0.8.4-1
“gdisk” 0.8.4-1 source package in Ubuntu

Ubuntu “gdisk” package - 0.8.4-1

  • New upstream release:
    • Fix FTBFS with gcc-4.7 (Closes: #667177)
    • Drop debian/patches/eof_stdin.diff, accepted upstream
    • Refresh debian/patches/manpages.diff (minor typo fixed upstream)

Uploaded by: Guillaume Delacour on 2012-04-20

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.