Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to run a .jar file on my computer. It worked in version 11.10, but in 12.04 now, I get a fatal error message from Iced Tea Web, saying it cannot parse the JNLP file. I've tried installing other Java clients but had no success, they don't even appear on the 'open with' list.

share|improve this question

Oracle Java 7 on Ubuntu 12.04 x64:

sudo add-apt-repository ppa:webupd8team/java

sudo apt-get update

sudo apt-get install oracle-jdk7-installer

I think due to 12.04 still in Beta theres no source list or something. I don't really understand everything yet, still learning myself.

Test if Java is Working:


share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.