Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My wifi connection drops sometimes and, for some reason, Network Manager attempts to connect to my neighbor's network, which requires a password that I don't know. The network in question is not listed in the "Edit Connections..." dialog and I can find no reference to it in any configuration file, but still the password dialog pops up every time my main connection drops. Is there a way to blacklist a wireless network so that the Network Manager will never attempt to connect to it? Or, equivalently, how can I remove the configuration data that causes the Network Manager to attempt to connect to this particular network?

share|improve this question
up vote 5 down vote accepted

Hm... not sure why NeworkManager behave this way. This should only happen if you have already added the wireless network in the list and Connect automatically is checked.... maybe is from a connection configured by another users and made available to all users.

You can try to manually add the wireless network and the uncheck Connect automatically.

share|improve this answer
The network wasn't in the Connections manager before. But clicking on the network, failing to connect, then going into the Connections manager and unchecking "Connect automatically" did the trick. Thanks! – Chris Conway Nov 8 '10 at 1:47

The phenomenon you saw might also be due to the wireless roaming that wpa_supplicant (which runs in the background) does at opportune moments, e.g., when your neighbors network has the same name as yours.

One way to stay on your own access point is to lock the saved connection to your APs MAC address. The MAC address of the connected Access Point is visible in iwconfig or in iw wlan0 link

Enter the MAC (or BSSID, same thing) here: alt text

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.