Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After wubi didn't work (error: prefix not found), I decided to perform a native Ubuntu install.

Before that I changed and checked my BIOS already.

First I downloaded an 11.10 iso from ubuntu.com and burnt a CD. Didn't boot.

Then I bought a 11.04 CD from a bookstore. Still didn't boot.

Next, I made a 10.04 USB drive. It booted and installed, but my computer shows grub rescue after the third bootup!

After 5 hours of restoring the windows bootloader, I borrowed the Ubuntu 11.10 Unleashed 2012 book from the local library. It came with the Ubuntu 11.10 DVD Edition CD. STILL didn't boot. Then I booted into nomodset mode and it still didn't boot. The book was new (according to the staff)!

This is what happened all the time: After it shows the purple screen I chose English and chose to try Ubuntu without installing. Then a blank screen with a flashing line appears, sometimes with a "prefix not found" message. It kept flashing for an hour.

What is the problem here? Any help will be appreciated!

Specs:

ASUS F81SE, 4GB RAM; came with 2 GB, Windows 7 Home Premium; was going to dual-boot

share|improve this question
    
When you say did not boot means that the CD is ignored of that its just stops after some time after attempting to boot? Still sounds like a problem with your BIOS settings or your CD drive. –  Bruno Pereira Apr 7 '12 at 18:48
    
Please give more details like kind of error, blank screen or what. What is meant by not booting? Did you change boot order? Grub rescue shows up means GRUB is not there where it should be (case like deleting partition containing grub) –  Web-E Apr 7 '12 at 18:49
    
After it shows the purple screen I chose English and chose to try Ubuntu without installing. Then a blank screen with a flashing line appears. It kept flashing for an hour. And I changed the BIOS to CD. Sorry for not providing the details –  Emerson Hsieh Apr 8 '12 at 0:48
add comment

1 Answer

up vote 2 down vote accepted

I had a similar situation with my Asus U46E. Try the following see if it helps (it worked in my case):

Right after selecting English in GRUB, hit F6, it will bring up a list of GRUP boot options. I checked nolapic and then it booted fine.

share|improve this answer
    
Thanks! I will try it. But what is the problem anyways? Is it a compatibility problem? –  Emerson Hsieh Apr 8 '12 at 6:25
    
It installed and booted, but it kept hanging at the purple screen! Help! –  Emerson Hsieh Apr 8 '12 at 18:41
    
It looks like you are having the exact same problem as mine. Follow this: 1) When you boot up the computer, at the moment showing the GRUB choices, hit the letter 'e' (for editing). Then you can edit the GRUB boot options. Add nolapic to the line for the choice of ubuntu. Then hit 'F10' (not sure, it will prompt you anyway) to continue boot. 2) once you booted ubuntu from your hard disk, edit grub option by 'sudo vi /etc/default/grub', insert the word 'nolapic' to the line GRUB_CMDLINE_LINUX_DEFAUT. Save the file. then run 'sudo update-grub' to update grub parameters. –  G. He Apr 9 '12 at 1:21
    
Thanks! Now it worked, but I can't connect to the internet to install the graphics drivers :( But at least I know that my graphic card is the problem –  Emerson Hsieh Apr 9 '12 at 1:28
    
This solution will let you boot ubuntu. But it is not without drawbacks. One major drawback is that (at least for my situation), the kernel may only recognized one of your multi-core cpu (if that's the case). In my case, the kernel only recognize one core of my dual core i7 cpu. Which is a bummer. I hope the problem get fixed in the newer version. –  G. He Apr 9 '12 at 1:28
show 3 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.