Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Is there a way to stop the new unity feature that changes the colour of the launcher and notifications that matches them to the wallpaper?

Its an interesting feature, but I would rather not have a yellow or brown launcher just because the wallpaper has some yellow or brown in the image, its pretty ugly.

share|improve this question

8 Answers 8

up vote 7 down vote accepted

Notifications

The chameleon effect can be removed from the notifications but it is quite an involved process involving installing an older version of the notify-osd package, a comprehensive guide can be found here: http://askubuntu.com/a/128508/40955 then the notifications will be the same dark colour as they were in 11.10 (or you can choose a custom colour)

Launcher

The instructions below currently do not work, due to Bug #975350

You can force the launcher to stay one colour and not change to imitate the wallpaper colour by installing the MyUnity tweaking tool from the Ubuntu Software Centre.

When installed navigate to the Launcher tab and click the color bar

Screenshot of MyUnity, clicking colour bar

Select your preferred colour from the colour wheel and the launcher will remain that colour no matter what the wallpaper colour is.

Screenshot of MyUnity, sampling from colour wheel

share|improve this answer
    
sounds great, does this work for notifications too? –  Jayo Apr 7 '12 at 14:46
    
I've just had a test an it doesn't work for notifications. There is a method to change the colour of notifications in 11.10 webupd8.org/2011/05/configurable-notifyosd-bubbles-for.html but I haven't tested on 12.04 I'll update my answer if I find a method that works. –  coversnail Apr 7 '12 at 14:56
1  
Once I've selected a new colour the panel does change to it however after a few seconds reverts back to what colour it was originally. –  KoopaTroopa May 22 '12 at 22:37

The chameleon effect cannot be turned off without reverting the source changes that enabled it.

Atm the means to alter the color used does not work, seen here in bug report though in one of the dupes a dev marked it as a wishlist which is curious https://bugs.launchpad.net/unity/+bug/975350

Additionally, even when working you are not able to use #000000 which would allow for a non-colored launcher, bug report here - https://bugs.launchpad.net/unity/+bug/924586

If the former bug is fixed you can achieve a near colorless launcher by setting a single color (r,b, or g) to a value of 1, adjusting the opacity to suit & using "Edge Illumination .." for launcher icons

If both bugs are fixed then you can use #000000 with some opacity to remove the colored effect

Update - both bugs now have a proposed fix up for review. Have tested here & now a custom color can be set including #000000 which depending on opacity set can negate the 'colored' effect

share|improve this answer
    
Could you tell us how? –  Bucic May 17 '12 at 20:12
    
you'll have to wait until the fix is merged & a new unity released in 12.04 (don't hold your breath) or patch & re-build unity youself. I have created a patch for this but this isn't the place to show how. Ask on UF if need be –  doug May 19 '12 at 14:26
    
Could you at least tell me how should I name the topic if I decide to ask on ubuntuforums.org? –  Bucic May 19 '12 at 15:35
    
"How to patch unity in 12.04 to fix custom colors" or something like that - note that performance on UF & some other Canonical servers is quite poor today, at times almost impossible. Maybe if things get fixed I'll do a quick how-to –  doug May 19 '12 at 20:54
    
Thank you! I won't get on it until monday or so though. –  Bucic May 19 '12 at 21:35

Just set a desktop background with a lot of the colour you want. That's what I do and it seems to work well. (ex if you want blue choose an ocean, if you want green choose some grass, etc)

share|improve this answer
3  
I know you can do that, but should fix the error. –  aceqott May 2 '12 at 9:10

The issue you are experiencing is because of the new feature of getting a more unified look on the desktop experience.

The goal is to match both the icon-bar and pop-up windows to match whatever wallpaper you have chosen.

Have a look at this video: http://www.youtube.com/watch?v=D6z6hn6wZlg

However, I think i saw a On/Off/Automatic dropdown somewhere regarding colorization of the icon-bar. But I cannot find it now. I will poke around to see if I can find it. And if I do I will get back here with an update.

Best Regards Fredrik L

share|improve this answer
    
Okay, thank you very much for the information. –  aceqott May 2 '12 at 18:53
2  
Actually, you get a LESS unified look with this "feature": Ambiance theme is made of blacks and browns. If Unity gets a blue or a green from your wallpaper, you get a brown theme + blue/green launcher = UGLY. –  Cmorales May 11 '12 at 11:55

The option is currently broken in 12.04. Custom color settings last only until you do anything else after setting

Bug report, fix proposed on https://bugs.launchpad.net/unity/+bug/975350

share|improve this answer

following script used as a startup application can do a fix. gconftool has to be called twice to trigger setting change:

#!/usr/bin/env sh

# wait until unity starts
while [ ! "$(pidof unity-panel-service)" ]; do sleep 1; done

# try reconfigure bg color
sleep 2
gconftool --set /apps/compiz-1/plugins/unityshell/screen0/options/background_color --type=string '#050505EE'
sleep 2
gconftool --set /apps/compiz-1/plugins/unityshell/screen0/options/background_color --type=string '#0A0A0AFF'
share|improve this answer

For 12.04 & 12.10

To stop the dash and launcher to use the same color of the wallpaper. You can use CompizConfig Settings Manager to override this behavior.

  • Open CompizConfig Settings Manager
  • Search for Ubuntu Unity Plugin and open it.
  • Click on Experimental tab
  • Now click Background Color option and enter your desired color for dash & launcher.

enter image description here


Normal Behavior

enter image description here

After applying the changes

enter image description here

share|improve this answer
    
Thanks, that works. –  Tobold Feb 20 '13 at 19:42

One workaround that doesn't involve forgoing the use of a background is to edit the colour of the central pixel, as described in this thread: http://ubuntuforums.org/showthread.php?t=1967347

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.