Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm new to Linux in general. I installed 11.10 the other day, and began enjoying. I've noticed, however, that when I choose "Ubuntu" from the login menu (vs "Ubuntu 2D), the system runs noticeably slower. Nothing major, but window movements are jerky, programs take longer to open, and log-in is substantially slower. When I load "Ubuntu 2D", everything is snappy.

My system is an Athlon II x4 @ 3.0 Ghz and an AMD 6770.

Ubuntu tells me that the proprietary drivers are non-active, but I did install catalyst earlier.

Something tells me this has to do with drivers. What's my next step?

share|improve this question
It seems that your current configuration is not rendering 3D acceleration fast enough. Did you try Gnome Classic per chance? You can try Gnome Classic in both 3D and 2D, see if you notice a difference there. If 3D is still slow, you may want to consider re-installing your driver. Did you install the Catalyst driver from a downloaded binary or from Synaptic? The one in Synaptic is essentially the one you see in the Drivers Manager. – titaniumtux Apr 7 '12 at 6:33

If you have installed the Graphics drivers through the software center or the 'Additional driver' button in system settings I would suggest to reinstall them using the newest driver package from the amd website.
It's a pretty straight forward process and done very quickly through the terminal, just copy and paste every command I put here.

sudo apt-get remove --purge xorg-driver-fglrx fglrx*

sudo apt-get remove --purge fglrx*

sudo apt-get install build-essential cdbs fakeroot dh-make debhelper debconf libstdc++6 dkms libqtgui4 wget execstack libelfg0 dh-modaliases

sudo apt-get install --reinstall xserver-xorg-core libgl1-mesa-glx libgl1-mesa-dri

sudo dpkg-reconfigure xserver-xorg

These commands remove the previously installed drivers and make sure all the dependencies for the new drivers are included.
These next ones download and activate the driver installer script from amd

cd $HOME/Downloads


sudo chmod +x

sudo sh --buildpkg Ubuntu/oneiric
sudo dpkg -i *.deb

The graphical amd installer will now guide you through the driver installation (just as it would in windows for example)
After it's done just type

sudo aticonfig --initial

Now reboot your system and see if the issue is resolved.

share|improve this answer

AMD graphics drivers are very poor on Linux. Happens to me on an AMD 6850 as well. Very jerky window movement.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.