Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I wanted to stop particular user names appearing in the list of names at the log in screen. I remembered reading that this could be achieved by changing the user id of the account to something less than 1000 (I think I made it 990). So I did this. That worked fine, but now when I wanted to change it back, the name is not appearing in the list of user accounts in the users and groups menu under administration.

How do I modify the phantom account?

share|improve this question
add comment

4 Answers

up vote 4 down vote accepted

You can change the userid with sudo usermod -u <new id> <username>.

Btw: to hide users from log in screen: How to hide users from the login screen?

share|improve this answer
add comment

gdm uses UID_MIN from /etc/login.defs to determine which user IDs are system users and which are regular users. If you adjust it to match your system's user range, gdm will show them at the login screen again.

For example, since users on my network have their uid start at 500, I changed /etc/login.defs so they could log in:

$ grep UID_MIN /etc/login.defs
UID_MIN          500
share|improve this answer
add comment

If the users/groups are not showing up on the graphical administration there is something wrong with your /etc/passwd, /etc/group files. Check the file contents, also from a terminal run:

sudo pwck

This will check for errors.

share|improve this answer
add comment

The gdm login lists ubuntu login user with a UID >=1000

So set this UID less than 1000 for the user which you dont want to show in the login screen.

Goto System -> Administration -> Users and Groups

Click the user name, go to advanced settings, then change the "User ID" to a different number less than 1000.

share|improve this answer
    
This isn't an answer to my question at all. I have already done what this answer suggeests. And the whole point is when I now go to System->Administratin->Users and Groups, the user isn't there –  Seamus Nov 7 '10 at 18:04
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.