Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I usually choose English as an installation language since I believe that the original is better than the translation. However, the environment I'm working in is mostly Russian, so I have to deal with locale specificity.

Even worse is the fact that selecting English yields to royal measurement system, that is, feet, inches, and damned letter paper size. Whatever I do, I didn't manage to get rid of letter paper size - eventually here and there I stumble upon letter as a hidden default, and that spoils my prints.

How can I select and use English as my language, but use metric system everywhere and a4 paper size everywhere, and Russian regional settings (date, time, decimal etc).

share|improve this question
add comment

2 Answers

up vote 3 down vote accepted

If you execute locale you can see the language variables that are used for various sections of the operating system:

LANG=en_US.UTF-8
LANGUAGE=en_US
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC="en_US.UTF-8"
LC_TIME="en_US.UTF-8"
LC_COLLATE="en_US.UTF-8"
LC_MONETARY="en_US.UTF-8"
LC_MESSAGES="en_US.UTF-8"
LC_PAPER="en_US.UTF-8"
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT="en_US.UTF-8"
LC_IDENTIFICATION="en_US.UTF-8"
LC_ALL=

More about locale variables in the gettext manual: Locale Environment Variables - GNU `gettext' utilities

You can export these variables e.g. export LC_PAPER="ru_RU.UTF-8" - this will make a temporary change.

If you want to make it permanent you can change the regional formats using gnome-language-selector. Or you can add the export command in ~/.profile and/or ~/.bashrc

For the papersize, I found that you can edit /etc/papersize - change "letter" to "a4". You might also need to set export LC_PAPER="en_GB.UTF_8" (or maybe export LC_PAPER="ru_RU.UTF_8" if ru_RU defaults to A4)

Source: answers.launchpad.net: Question #6846 : Questions : “evince” package : Ubuntu

P.S. Personally I use en_GB (English / United Kingdom) for everything since it uses the SI metric system instead of American English and US units.

share|improve this answer
    
Problem is that /etc/papersize works only for those programs that use libpaper or read and honor it. For example, OpenOffice ignores this file. Also, gnome-language-selector is only relevant to gnome environment. –  mbaitoff Apr 7 '12 at 10:55
    
1. Fair enough, but I believe I gave alternatives. 2. I don't know about OpenOffice, does this happen with LibreOffice too? 3. Maybe there's no way to set it in *Office, but there was no feature request about locale paper size support. Have you filed a bug/feature request upstream? 4. Instead of gnome-language-selector you can set your locale-related variables in ~/.profile /etc/profile or /etc/environment if the profile files don't do the trick. 5. gnome-language-selector works in gnome 2/3 and unity AFAIK. You could mention which desktop manager you use. :) –  medigeek Apr 11 '12 at 23:26
    
All 1-4 agreed. As for 5: since Unity and since gnome2 is no more, I prefer using xfce/lxde. –  mbaitoff Apr 14 '12 at 5:43
    
@mbaitoff editing /etc/default/locale did the trick for me –  Alexander Malakhov Mar 28 '13 at 4:14
1  
@mbaitoff: I had a single line in it LANG="en_US.UTF-8", and all other settings defaulted to that locale. The only thing I wanted different was weeks to start from monday (not sunday). So I added LC_TIME="en_GB.UTF-8" (I didn't have Russian locale installed). All parameters' names should be the same as what you get from locale command. Or you can just try en_GB locale (change LANG value) as medigeek suggests. –  Alexander Malakhov Apr 1 '13 at 2:42
show 1 more comment

Whatever I do, I didn't manage to get rid of letter paper size - eventually here and there I stumble upon letter as a hidden default, and that spoils my prints.

There are 2 locale settings. Settings of whole system and settings of LibreOffice.

1) Please find option Language Support in your OS. There will be 2 tabs: 1st - Language; 2nd - Regional formats. It is setting for currency, number and date format in Russian. Let choose Russian than click Apply System-Wide button. Reboot or restart.

2) LibreOffice have own locale/size settnigs. In LibreOffice menu: Tools → Options → Language settings → Languages → Locale settings → Russian. Also! Tools → Options → LibreOffice → General → Measurement unit → cm (instead inch)

Reboot or restart LibreOffice.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.