Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

After system update yesterday, all browsers on Ubuntu 11.10 seem to be crashing. The system is almost unusable because browsers have been essential these days. There is no way to use any browser for more than 2 minutes. I tried the steps mentioned in a related issue like reinstalling nvidia-drivers and libvdpau1 but those did not help. I am um unable to see any open bugs too.

share|improve this question
Launch it in a terminal and give us the output (by editing this post), we can't help otherwise. – Bahaïka Apr 6 '12 at 7:20
Open terminal, type google-chrome and paste here log from terminal (last few lines of error). Maybe that show where is error. – Bartek Apr 6 '12 at 8:17
Not just Ubuntu either. Also happening on Arch after kernel update yesterday. Booting older kernel improves matters, but still buggy where flash is involved. Looks like a bad kernel issue. – user53749 Apr 6 '12 at 15:15
up vote 2 down vote accepted

it's something in the kernel. booting into -17 rather than the new -18 solves the problem (i had the same issue)...

This is after a kernel upgrade which happened yesterday. The following Launchpad bug tracks that

And here the patch for solving the issue.

The patched kernel solved the problem for me. I think, the next kernel upgrade should resolve it.

share|improve this answer
Let me try that, because it was indeed a kernel upgrade that happened yesterday. – Senthil Kumaran Apr 6 '12 at 9:52
How to boot to old kernel? – Senthil Kumaran Apr 6 '12 at 13:27
On Ubuntu this patch solved the problem - – Senthil Kumaran Apr 6 '12 at 15:35

Been having the problem with 11.10. Even after all updates for 11.10. Both Chromium and Firefox had similar symptoms. Flash applets would not run. Youtube would not play. But if you shut flash off in firefox, then some videos would play, and others wouldn't. I even tried the firefox add-on called flash aid. Very easy to use, but still didn't fix it.

Now get this, if you install Google Chrome, stable version for Ubuntu (or just go here), it works great on youtube and flash. Then if you run flash aid in firefox, it will let you select "Google from chrome" as one of the possible flash options. Select it. Also select the rest of the defaults. It will have flash working great in Firefox and Chromium too with version

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.