Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Before I installed Ubuntu, I resized my C: drive (which has my Windows 7 OS). Prior to resizing, I even defragged the said drive. I tried using Wubi to install it on the created partition, but I receive an error. I have the log file and I would post it but it's too long and the site won't let me. :(So anyway, I wasn't able to install it, so I uninstalled it. Upon uninstalling Wubi and Ubuntu, I tried installing it by having the CD to my CD ROM. The installation was a success, however, upon rebooting I can neither boot to Ubuntu OR Windows 7. I get stuck in an infinite bootloop. I hope you can help me out!

:(

share|improve this question
    
Post the log file on pastebin.ubuntu.com. –  William Apr 6 '12 at 2:14

1 Answer 1

Maybe the Windows Boot Manager was removed. To reinstall Windows Boot Manager, try the following to have access of Windows's boot recovery programs:

Access to the Command Prompt

  1. Boot with a Windows 7 installation CD;
  2. Press a key when you are prompted;
  3. After selecting a language, a time, a currency, a keyboard or an input method, click next;
  4. Choose Repair your computer option;
  5. In the next menu, select any operational system to repair, click in Next
  6. Now, click in Cancel button;

MBR Fix

If everything went fine, you have access to theprompt. Now, use the following commands to fix the MBR:

bootrec /fixmbr
bootrec /rebuildbcd
bootrec /fixboot

If no error messages are returned, you can reboot your computer and try to boot on your OS. If it does not work, there is two other options remaining try.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.