Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am trying to get to work skype-wrapper on ubuntu 12.04 (x64)

I tried to follow these steps http://www.omgubuntu.co.uk/2011/10/how-to-add-skype-to-the-ubuntu-messaging-menu/

Also I tried to download and install it manually but it doesn't work, nothing just happens when I run skype-wrapper

Can anybody advice me how to solve it?

share|improve this question
any chance to turn this into a wiki? I feel there is a need for a proper installtion guide... –  n3rd Sep 23 '12 at 23:43
I believe the pre-req for making a wiki is starting a bounty. –  Jason Mar 30 '13 at 18:42
add comment

4 Answers

  1. Quit Skype if running

  2. Uninstall Skype IF you installed it from the repositories.

  3. Reboot

  4. Choose your Skype version (32/64 Bit) to download and install it

  5. Make sure you added the repository ppa:skype-wrapper/ppa

  6. In terminal console, run

    sudo add-apt-repository ppa:skype-wrapper/ppa
    sudo apt-get update && sudo apt-get install skype-wrapper python-skype
  7. After that, run in terminal console

  8. Acknowledge the pop up authorization requests (don't forget to check the boxes to remember the selection)

  9. Restart and done!

This is how I got it working.

share|improve this answer
doest not work for me w/ latest Skype 4.0. I can see in the terminal that Skypewrapper tries to connect to Skype, but whenever I klick on allow app in Skype it pops up a new question. Klicking on cancel crashes Skype. –  n3rd Jun 18 '12 at 15:35
This solution was tested with the pre 4.0 Skype. Even though, I uninstalled the old version and replaced it with the official Skype 4.0 which worked fine for me. Perhaps you find help here omgubuntu.co.uk/2012/05/… –  offline Jun 18 '12 at 16:01
Got it working with Skype 4.0 after a fresh install of Ubuntu 12.04. Works for now...Thx –  n3rd Jun 18 '12 at 19:10
Tried the proposed solution, but got an error on step 7, where the indocaor applet crashes. The wrapper troies restarting, but never does... pastebin.com/zdwhY5zs –  poumtatalia Feb 24 at 8:29
add comment

Do what MrMuretto says, and it should work. However, I wanted Skype to always launch using the wrapper. To do that, you need to modify /usr/share/applications/skype.desktop (with sudo) and add the line:


after the line "Terminal=0". Next, modify /usr/share/applications/skype-wrapper.desktop (with sudo) and remove the line:


This will allow skype-wrapper to launch from dash as a true wrapper.

share|improve this answer
echo " + 1 " >> downbeat –  One Zero Jul 28 '12 at 20:15
Can you explain why this works? –  Syzygy Nov 29 '12 at 21:34
Apparently the "NoDisplay" attribute in a .desktop file means exclude from dash (and probably some other things as well). If neither had the NoDisplay entry set, I believe you would see 2 identical entries for "Skype". Either that or only one but it would be unclear which one would start when clicked (the app itself or the wrapper). By setting the wrapper to display and the Skype app itself to hide (NoDisplay=true or 1), we are making only the wrapper show up in dash as "Skype" (and possibly elsewhere), which is exactly what we want. –  downbeat Jan 4 '13 at 0:17
add comment

I had same problem.

If the steps from above doesn't prove working I made it work by installing python-wnck Install python-wnck package.

sudo apt-get install python-wnck

I beleve that you can find this package in Ubuntu Software Centre.

share|improve this answer
add comment

Skype can be installed from Software Center. At least, starting from Ubuntu 12.04. Because the repositories for Skype have been updated.

share|improve this answer
-1, sorry. Skype =/= Skype Wrapper, they are different. –  Tom Brossman Sep 24 '12 at 8:29
add comment

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.