Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am running on Ubuntu 11.10 32 bit, and my flash player plug-in for Firefox is outdated. I must update my plug-in to flash player 11, but I am not able. I have already installed Adobe Flash Player via Ubuntu Software center (As it prompted me to after trying to download from the Adobe site) Without the plug-in updated, videos can not be played from directly on a Facebook page, and I believe that it distorts the video player on Youtube. (Image of player can be seen at imgur.com/gYbFx)

share|improve this question

closed as off-topic by RolandiXor Sep 2 '13 at 17:46

This question appears to be off-topic. The users who voted to close gave this specific reason:

If this question can be reworded to fit the rules in the help center, please edit the question.

    
@EliahKagan No upvoted answers, and the one that likely will help is invalid right now –  Braiam Sep 2 '13 at 20:36
    
My suggestion: Do not reopen this question: It's no longer relevant and all the answers are hopelessly outdated. –  RolandiXor Sep 2 '13 at 21:47

3 Answers 3

Try this.

sudo apt-get purge flashplugin-installer
sudo apt-get install adobe-flashplugin

Then, open up a YouTube video, right-click on the video itself and click on Settings.

Uncheck the "Enable hardware acceleration" checkbox in the Display tab.

Your Flash video should now work.

share|improve this answer
    
Neither command worked, saying that my plug-in was up to date when I know it is not. I was unable to reach the "settings" after right clicking the video on YouTube, the choices consisted of file, edit, view, movie control, and help none of which contained a display tab or check box for "enable hardware acceleration." –  George Apr 6 '12 at 0:26
    
It worked for me –  0x4a6f4672 Apr 10 '12 at 12:31

I did this for Ubuntu 11.10. Download google chrome(not chromium but chrome from google, not the repos), find where the flash file for chrome is located in your directory, it's called "libgcflashplayer.so". Copy it to your desktop and change the name to "libflashplayer.so". Find where Mozilla Firefox keeps the Flash file for Firefox in your directory and replace it with the one you just changed the name of. To replace it I used rootnautilus, drag and drop, just type in gksudo nautilus in terminal. It worked for me. I even replaced it with an archived version of adobe flash 9 and it worked, but the version in Chrome is 11.

share|improve this answer

Try to install this add-on on firefox :

https://addons.mozilla.org/en-US/firefox/addon/flash-aid/

After installation, click on "quickmode" and "install stable flash". It will open your terminal, remove the old version and install the new one.

This fixed my problem. Good luck!

share|improve this answer
    
This fixed my problem too! –  Rishabh Nov 8 '12 at 8:01
    
This add-on has been removed by its author. –  Denja Apr 20 '13 at 15:59

Not the answer you're looking for? Browse other questions tagged or ask your own question.