Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have installed Ubuntu 12.04 (Precise Pangolin). If I open System Settings >> Displays there is a new (?) on/off button for a setting named Sticky edges.

Can someone tell me what this setting is supposed to control?

share|improve this question
    
Related question/answer--adjust the stickiness factor: askubuntu.com/a/224938/54675 –  Eric Lambart Jan 14 at 20:16

5 Answers 5

up vote 17 down vote accepted

It controls the mouse behaviour at the edges between monitors in a multi-monitor setup: If "Sticky Edges" is enabled the mouse stops on the edge.

See bug #965080 if you think this should be more obvious.

share|improve this answer
1  
What I find a tad confusing is that, if I am understanding this correctly, this option is concerned with how the system behaves when you have multiple displays. I only have a single display. Oh, well. Thanks for the link to the bug entry. I'll wait and see if anything changes. –  irrational John Apr 5 '12 at 19:31
    
@irrationalJohn IKR! It should be disabled or greyed out atleast when there's a single-monitor setup and also turned off by default. –  YatharthROCK Dec 5 '12 at 16:10

The answers by UbunTom, Jeff Welling, and Jayson Rowe, are all correct.

In fact, the accepted answer (with 10 votes currently) is completely wrong. Unfortunately, even the bug entry found in the accepted answer gets it partially wrong (not the first poster who says he doesn't know, and not Simon's answer, but some of the responses that suggest to relabel the sticky edge with the expected behavior of the mouse sticking to the edge).

The sticky edge toggle actually has absolutely no bearing on the mouse sticking to the side of the screen of a multi-monitor set up. I know this because I'm currently typing this from a multi-monitor set up. And even when this toggle is turned off (and the change is applied), my mouse still sticks a little bit to the side of the screen positioned adjacent to my second monitor (before it crosses over completely to it).

What this setting controls however is the semi-maximizing property of windows when the cursor touches the side of the screen while it's dragging a window bar to it.

Jayson Rowe nailed the description of the behavior in his comment:

It kinda does in a multi-monitor setup - for example, with it turned off, a window will not semi-maximize on the left-hand side of the right-hand monitor, but it will when it turned on. – Jayson Rowe

In my personal experience of using this setting both in a single monitor set up (when I'm on my laptop), and of using this setting in a multi-monitor set up at home when my laptop is connected to a second additional screen. I find that this sticky edge toggle should always be left turned on (Although, Simon in the bug entry seems to disagree with me, because he's so used to be able to drag windows from screen to screen smoothly, he hates it when that doesn't do that).

In either case, this makes me think that the person, who originally envisioned this setting and designed the UI for it, is probably not the same person who implemented it programmatically. And that's probably the bug, that this setting was originally meant to toggle the mouse sticking to the edge, but the person implementing it, took it to mean that it should toggle the windows sticking to the edges instead.

share|improve this answer
1  
This is completely incorrect based on my experience. I am using 12.04 with a 2-monitor setup and the only thing it changes is the mouse behavior. I am still able to 'semi-maximize' a window by dragging it towards the junction of the two screens (it 'semi-maximizes' when the cursor, not the window edge, reaches the junction). With the 'Sticky Edges' enabled, it tries to grab my mouse cursor every time I move across the monitors. Can't imagine why anyone would want that, but at least it's easy to turn off. –  Eric Lambart Jan 14 at 20:14
    
In case it's relevant, I should mention that I have the "launcher placement" set to a single display. If I had the launcher on both displays, this 'sticky edges' feature might be helpful. –  Eric Lambart Jan 14 at 20:18
    
Well, I'll try it again tomorrow. May be there was an update, or may be there is something else that's different with my setup. –  Stephan Branczyk Jan 15 at 8:07

I found that if you simply disable sticky edges the mouse gets stuck on the other display. This is probably intentional, because launcher placement would not make any sense for both displays if you cannot select the launcher on the other display.

So what you need to do is Settings > Displays set sticky edges to OFF and set launcher placement to only one monitor.

share|improve this answer

I dont know for sure but it sounds like that toggles the ability to drag a window close to the edge and have the window jump to that edge, lined up perfectly.

share|improve this answer
2  
It kinda does in a multi-monitor setup - for example, with it turned off, a window will not semi-maximize on the left-hand side of the right-hand monitor, but it will when it turned on. –  Jayson Rowe Apr 5 '12 at 19:02

It allows you to position the edge of a window next to the edge of the screen

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.