Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Provide my spec and sorry for my poor English first.

  • MB: Gigabyte G31M-S2L (bios ver. F9)
  • CPU: intel E5200
  • 2G RAM
  • HD1: WD 160G with 2 partitions (partition 1:60G, NTFS, win xp; partition 2:100G, NTFS)
  • HD2: WD 320G with 2 partitions (partition 3:220G, NTFS; partition 4:100G, ext4, Ubuntu)

Recently, I tried to install Ubuntu 12.04 Beta 2 on my desktop PC (on partition 4).
At the beginning, everything looked great including the auto-mounting of partitions 1~3 and the unity (3D).

However, after I deleted and re-allocated the partitions on HD2 and re-installed Ubuntu on partition 4, the partitions 1~3 are no longer auto-mounted when I logged in the desktop (and even the inserted cdrom would not be mounted either).

The configurations during these two installations are all the same as default.

Are there any possible reasons or solutions for this issue?

share|improve this question

closed as off topic by Jorge Castro, fossfreedom May 22 '12 at 18:16

Questions on Ask Ubuntu are expected to relate to Ubuntu within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

    
Thanks forespiskie! I've tried the commands in the terminal. However, there seems nothing happened. :( Any other methods may I try? It is also strange that, at the second time I installed Ubuntu 12.04, the panel and launch bar are not shown in unity (3D), but work fine in unity 2D. The panel and launch bar just work fine in unity (3D) at the first time I installed Ubuntu 12.04. –  user53704 Apr 6 '12 at 6:18
    
Try again - they are seperate commands - formatted ny answer. –  Elfy Apr 6 '12 at 6:24
    
The launcher and the top menu missing in Unity is a bug. I believe it was fixed in one of the updates. Try updating your system and see if that fixes your problem. (Meanwhile, I am removing that part from your question.) –  jokerdino Apr 6 '12 at 8:44
    
@nuit - please register one of your accounts - you have two similar accounts at the moment - I can merge them for you. Thanks. –  fossfreedom Apr 6 '12 at 8:49
    
Here is the link to the bug report - bugs.launchpad.net/ubuntu/+source/unity/+bug/963633 –  jokerdino Apr 6 '12 at 9:03

1 Answer 1

Open a terminal and run these commands after mounting the drives in Nautilus please.

sudo fdisk -l    
cat /etc/fstab
sudo blkid
mount

Generally partitions will only be automounted if they are told to - they might appear in the sidebar of Nautilus - that does not mean they are actually mounted.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.