Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a NTFS Partition that I want to be mounted on every startup. Currently Kubuntu tells me on every startup There have been errors checking the filesystem and then stops the boot process until I told it to ingore or skip or manually recover from the errors. If I press skip the partition gets mounted and everything seems to work fine.

If I mount that same partition with sudo mount /media/Windows_Data after startup I get no errors whatsoever.

The corresponding part of the fstab file:

UUID=F444E6DC44E6A09A   /media/Windows_Data     ntfs    defaults,users,auto     0       2

This is what /var/log/boot.log has to say to this:

/boot.log:mountall: fsck /media/Windows_Data [424] brach mit dem Status 8 ab
/boot.log:mountall: Nicht behebbarer fsck-Fehler: /media/Windows_Data
/boot.log:Fehler auf /media/Windows_Data werden auf Anfrage des Benutzers ignoriert

Unfortunately thats in german so I will try to translate that

/boot.log:mountall: fsck /media/Windows_Data [424] stopped with status 8
/boot.log:mountall: Not recoverable fsck-Error: /media/Windows_Data
/boot.log:Errors on /media/Windows_Data will be ignored due to user request.

Any ideas what I can try to get this error fixed?

share|improve this question
    
you should also have a look at fsck.ntfs, see this page on super-user –  Dirk Hartzer Waldeck Apr 7 '12 at 21:11
    
I ran fsck.ntfs, but it didn't find any errors and did not correct this issue. –  FlyingFoX Apr 20 '12 at 15:39
add comment

2 Answers 2

It seems like you need to run a check disk on your windows partition; in Windows. You can do this by running the program CHKDSK on your Windows Operating System. You will encounter this error possibly every time you don't properly shutdown Windows; don't you love NFTS file-systems?

If for some reason you have possibly encrypted your partition, that would provide errors as well; but that is really abnormal.

share|improve this answer
    
I tried running the Windows disk checking through the GUI menu that you get when right clicking the partition and selecting properties, but that didn't fix this issue. I will try the CHKDSK utility the next time I boot into windows. –  FlyingFoX Apr 20 '12 at 15:38
    
There is a method to force it during startup, have you tried this? –  RSX-1327 Apr 20 '12 at 17:32
    
no, but it got unmounted right away and then checked it for like an hour or so. It is not my primary windows partition, just a data partition that i use to share stuff between windows and linux. –  FlyingFoX Apr 20 '12 at 18:37
add comment
up vote 0 down vote accepted

Updating to Ubuntu 12.04 seems to have fixed this.

The boot process doesn't get interrupted by mount errors any more and the partition is mounted after login and seems to work fine.

There seem to be no errors concerning this partition in /var/log/ as well.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.