Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I cant play starcraft 1 in Gnome shell(to slow), in unity runs perfect .Why?

share|improve this question

2 Answers 2

This could have to do with Compiz, it could also have to do with your graphics drivers, but I'm not sure which or if there's more that I'm missing.

Check compiz to make sure that the state is the same in both Unity and Gnome, and check to see which graphics drivers are in use.

I may be missing other variables at play here.

Edit: I just remembered that Starcraft doesn't run natively on *nix so you must be using wine -- check the wine settings for any differences when you run in Gnome compared to Unity.

share|improve this answer
    
ok, i'll check compiz –  user50899 Apr 5 '12 at 14:59
    
I remember im not using compiz, i installing but doesnt work –  user50899 Apr 5 '12 at 15:21
    
It just occurred to me now that Starcraft doesn't run natively on *nix, so you're likely using Wine or a derivative; check the settings in Wine? Perhaps by some freak chance the settings are different in Unity and Gnome? I'm grasping at straws now to be honest. –  Jeff Welling Apr 5 '12 at 15:24

mutter could grabbing 3d accelation from your card, and compiz doesn't , compiz has had lots of work over the years to help speed up full screen 3d applications

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.