Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I use gnome network manager it indicates that wireless is disabled by hardware switch while it is not. Even in windows I can not turn on my wireless!

share|improve this question
    
How, and in which OS, did you enable Airplane mode? –  Jeff Welling Apr 5 '12 at 13:35
    
in Ubuntu 12.04 –  Ameno Apr 5 '12 at 13:38
    
Ok, that answers part of my question, now how did you enable airplane mode? Was it in a menu? If so, was it labelled 'Enable Airplane Mode'? I don't see any such option on my Ubuntu machine. –  Jeff Welling Apr 5 '12 at 13:42
    
yep, in network there is Airplane mode in right corner and I turn that on, but when I turn it off and close that windows and reopen network its on!!! –  Ameno Apr 5 '12 at 13:52
3  
Possibly you should file a bug - 12.04 is still in development! –  Jakob Apr 5 '12 at 14:39

4 Answers 4

I just tried this:

shell> sudo rfkill list all

The output was something like this:

0: sony-wifi: Wireless LAN
Soft blocked: yes
Hard blocked: no
1: sony-bluetooth: Bluetooth
Soft blocked: no
Hard blocked: no
2: phy0: Wireless LAN
Soft blocked: yes
Hard blocked: yes
4: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no

Then I have run this command:

shell> sudo rfkill unblock wifi

and all is fine now :) Have fun :) I hope it will help you :)

share|improve this answer

To explicitly check your wireless is turn off by hardware switch or not, you can use

sudo rfkill list all

Then you can use this command to unblock every blocked component there:

sudo rfkill unblock all
share|improve this answer

I think this is just a new manifestation of an old problem that affects Vaio laptops. I have one too, ran into the same problem with 12.04 (beta 2), and had success using the same solution I used with Ubuntu 11.*:

sudo rmmod acer_wmi
sudo rfkill unblock wifi

Let me know if that works for you. I think Ubuntu gets confused by having both "sony-wifi" and "acer-wireless" (which you can see in the previous answers "sudo rfkill list all"), and the rmmod will clear the "acer-wireless" option.

A more permanent version of this solution, suggested on this thread http://ubuntuforums.org/archive/index.php/t-1859633.html, is to just blacklist it by adding

blacklist acer_wmi

to

/etc/modprobe.d/blacklist.conf

and then restarting your system.

share|improve this answer

Check your BIOS settings. In my laptop's BIOS, there is an option of shutting down Wireless, Bluetooth and other networking interfaces.

The other problem might be that there is a physical problem with your Wireless hardware

The other case might be that your hardware is blacklisted. Check if the module is blacklisted in

cat /etc/modprobe.d/blacklist.conf

if it is not present in this, check other blacklist files in /etc/modprobe.d/ folder


Additionally please check that in Network in System Settings the interfaces listed on the left have ON toggled for Wired and Wireless. I am using Wired, so only one is showing. In your case both should show

enter image description here

share|improve this answer
    
my laptop is vaio and there is no such settings in Bios! –  Ameno Apr 5 '12 at 13:38
    
Did you check each and every settings? –  Manish Sinha Apr 5 '12 at 13:39
    
yep, eveeeeery setting, problem is some of vaio's bios is awful with no setting in Bios page! –  Ameno Apr 5 '12 at 13:40
    
my lan setting work correctly right now but wireless is off and I cant turn it on! –  Ameno Apr 5 '12 at 13:41
1  
I cant turn on wireless, each time I open this window airplane mode is on and if I turn it off it cause no effect! and I cant turn my wireless on because it said wireless is disconnected by hardware switch!! which is not! –  Ameno Apr 5 '12 at 13:55

protected by Community Jul 19 '12 at 6:24

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.