Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I added a new hard drive (sdb1, 500GB) to my system Ubuntu 11.10. I found this line on the Ubuntu help which I added to /etc/fstab

#new hard drive sdb1
UUID=48DCF742DCF728B8   /NewDisc    ntfs    defaults    0   2

But I kept getting boot errors that the system cannot mount new hard disk as it has serious errors. The disk has only one partition occupying all its space, NTFS, created and formatted via Windows 7 which is on the other partition (sda5) and it had only a few test files on it.

Then I noticed that in fstab file that the system added another NTFS partition like this

# /windows was on /dev/sda4 during installation
UUID=BC7A37A77A375D78 /windows        ntfs    defaults,umask=007,gid=46 0       0

What is the difference between these two entries?

Funny thing is when I change the new hard drive entry in the fstab file to

#new hard drive sdb1
UUID=48DCF742DCF728B8   /NewDisc    ntfs    defaults,umask=007  0   0

I stop getting boot errors. But I am not sure if this is the right thing to do and if I can keep such settings (umask and last digit o)???

Please help!!!

EDIT

A result of cat /proc/partitions

major minor  #blocks  name

   8        0  312571224 sda
   8        1          1 sda1
   8        2   39062047 sda2
   8        3  201945082 sda3
   8        4   48122880 sda4
   8        5   21374419 sda5
   8        6    2064321 sda6
   8       16  488386584 sdb
   8       17  488383488 sdb1
share|improve this question
    
what is the output of cat /proc/partitions –  jet Apr 5 '12 at 14:21
    
@jet no partitions. Just one big partition (500gb) created via another Win7 –  ubuntico Apr 5 '12 at 19:06
    
doesn't matter, I need to see the number of the new disk –  jet Apr 5 '12 at 22:16
    
@jet I'll edit the question now –  ubuntico Apr 6 '12 at 7:43

1 Answer 1

up vote 0 down vote accepted

If you're not worried about the files on the new hard drive, why don't you reformat the drive and put a new NTFS partition on it.

Just take out the line from /etc/fstab and restart the computer into Ubuntu. Open something like GParted and delete existing partitions from the hard drive. Then create a new one of type NTFS. And finally, reinsert that line into /etc/fstab (the first one, but with a 0 in the last column instead of a 2:

UUID=48DCF742DCF728B8 /media/windows ntfs defaults 0 0
share|improve this answer
    
I will try this and let you know of a result. Thanks. PS. the disk is new and it's empty ;) –  ubuntico Apr 5 '12 at 19:06

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.