Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

currently running Ubuntu 11.10. my wireless connection to our router has already been established but when i open Firefox, the page says server not found.please help me

share|improve this question
    
It's disappointing that so many people forget that pinging google.com still requires a name lookup. When your testing connectivity you should always try both an IP address and a dns name when pinging. This will tell you straight away if you have a DNS problem. Details are in my answer below. –  Jeff Welling Apr 5 '12 at 14:59
add comment

4 Answers

I would suggest resetting your Router and your Modem (if you haven't done so already). In case you haven't I would suggest powering down your modem, router, and PC. Wait 30 seconds and power up your modem...wait 45 seconds to 1 minute and power up router...wait 45 seconds to 1 minute and then power up your PC.

I think this should fix it by resetting the IP connection. I know this works all the time with Windows.

share|improve this answer
    
LOL...please explain the negative vote please...basic troubleshooting 101?? –  daslinkard Apr 5 '12 at 19:44
add comment

Try this, go to terminal and try ping 8.8.8.8. I know you've tried pinging google.com and that it fails, but the difference between pinging google.com and 8.8.8.8 (both are Google) is that 8.8.8.8 doesn't require a name lookup in order to test connectivity.

If the ping to 8.8.8.8 is successful, then you have a DNS problem, and should try changing your DNS settings to use Google's DNS servers (8.8.8.8, 8.8.4.4)

If the ping fails, then you have no internet connection at all, and need to either configure the router or modem properly. Your best bet for configuring the modem would probably be to contact your ISP. Most routers are plug-n-play so that shouldn't need configuring, but if it does we can help you with that as well.

If you know how, try logging in to the router to check the status of the internet connection on the router. It's possible, though unlikely, that the internet is getting to the router but no further.

Edit: Also, though this probably goes without saying, check that you have the modem plugged into the correct port on the back of your router. There are usually 4 or more regular ports, and one 'uplink' port where the modem plugs in. If you plug it in to the wrong port, you will likely have network trouble.

share|improve this answer
    
Thanks for this. I can ping 8.8.8.8 but not www.google.com. How should I go about changing my DNS settings the way you recommend? –  cboettig Jul 14 '12 at 15:11
    
Ah, never mind, seems these instructions worked: developers.google.com/speed/public-dns/docs/using Thanks for a great answer. –  cboettig Jul 14 '12 at 15:20
add comment

try the following command in terminal

ping google.com

If it reply then your internet connection is ok, problem is in firefox. Maybe firefox is using proxy, to disable it Go to Edit>Preference>Advance>Network. select Settings for network and check no proxy.

If you can not ping that means something is wrong in routing. Check your router that is it provide service for specific(mac address filtering) machine? make sure your device mac address is in router

share|improve this answer
    
i tried ping google.com ping: unknown host google.com –  Jeff Dela Cruz Apr 5 '12 at 5:23
    
Right-click on network icon (gnome-panel) and select connection information. Take a screenshoot(alt+prnScr) and post the image. –  shantanu Apr 5 '12 at 5:50
    
    
that was the image @shantanu –  Jeff Dela Cruz Apr 5 '12 at 9:24
    
Don't forget, failure to ping a DNS name could also be indicative of DNS problems, it isn't always an automatic indication of IP connectivity problems. –  Jeff Welling Apr 5 '12 at 15:04
show 3 more comments

Try

1.ping www.google.com in terminal

2.if its work then do ifconfig and see which eth0 or eth1 or so.... connected

3.then do it ifup eth1 or eth2 or any other which is connected in the system.

share|improve this answer
    
i tried ping google.com ping: unknown host google.com –  Jeff Dela Cruz Apr 5 '12 at 9:37
    
your net connection good ? –  raaz Aug 29 '12 at 20:00
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.