Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Salutations!

So, once again, I fell to the allure of the window decorator emerald. Where, just like the first time around, (I know I know) upon attempting to back out of emerald to the safety of compiz I'm faced with a problem.

Seemingly after several minutes or after opening Chrome any window that isn't maximised has it's borders removed (so there's no close, minimise and maximise etc buttons). I can get them breifly back if I reload compiz via fusion-icon. After a brief chat on IRC it appears compiz is crashing. Here's a pastebin log of me running compiz via terminal.

http://pastebin.com/sK65v4Fi

I forgot my two vows of 'Never bother using Windows applications via wine or a VM' and 'Thou shalt never not use compiz'.

***GTK-Window-Decorator log

gtk-window-decorator    
(gtk-window-decorator:11027): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",
Segmentation fault

** also posted on ubuntuforums to widen my scope of help.

share|improve this question
    
Which Ubuntu?.. –  Uri Herrera Apr 5 '12 at 1:02
    
11.10. Needless to say I wish to remove emerald and go back to using compiz. –  KoopaTroopa Apr 5 '12 at 14:08
    
compiz and emerald working in perfect harmony over here. using xfce however. –  duffydack Apr 5 '12 at 17:27

1 Answer 1

up vote 0 down vote accepted

Okay I've managed to fix it. If your also getting a segmentation fault when running gtk-window-decorator then this may solve the issue.

It appears that the ~/.gconf/apps/compiz-1 and compizconfig-1 folders are the culprit of this problem. I deleted them both and logged in and out again. This will create the two folders again and stop the borders missing issue and you can now happily carry on as usual.

You may want to backup your apps folder to put back some settings. I wanted my launcher back the same way and so I...

copied the 'unityshell' folder from the ~/.gconf/apps/compiz-1/plugins/ directory as well as from the ~/compizconfig-1/profiles/Default/plugins directory. Then pasted the two 'unityshell' folders back in their newly created compiz-1 and compizconfig-1 folders respectively and this gave me back my nice unity dock.

Have funzies!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.