Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed acroread from the repositories, and it has decided it should be the default plugin in Firefox, such that when I click on a pdf, it opens in a Firefox window. Unfortunately, it does not display (at least when in dual head mode).

This should be simple, but I cannot disable the plugin. Under Firefox Edit -> Preferences-> Applications -> pdf is set to "always ask" so I don't know why it uses acroread in the first place. Under Tools -> Manage Content Plugins I see acroread is selected for pdf content. I have the option in the dropdown to search for a new plugin, but not to simply download the file.

Typing about:config into the Firefox toolbar gives me a list of configuration options, but does not mention plugin.disable or acroread anywhere.

How do I disable the plugin? I have Firefox 11.0 on Ubuntu 11.10

share|improve this question

2 Answers 2

up vote 1 down vote accepted

I you want to get rid of the plugin permanently, because it is not removed by apt if you remove acroread, you have to delete it manually:

sudo rm /usr/lib/mozilla/plugins/npwrapper.nppdf.so

That worked for me on Ubuntu 13.04

share|improve this answer

You go to extensions, and there you can disable: enter image description here

share|improve this answer
    
If this is now what you are searching for, I will delete the answer. –  gajdipajti Apr 4 '12 at 22:30
    
That's it, thanks! Sounds like the behaviour I described is a known bug, and toggling the Application preferences to acroread and then back to always ask would work too. See the comments in this question –  cboettig Apr 5 '12 at 16:41
    
this issue is not resolved, as the plugin only seems to be disabled, but effectively is not and the entry will re-appear: cf with this unresolved bug for instance... –  nutty about natty Mar 5 '13 at 7:36

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.