Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've primarily used Windows, but recently switched to Ubuntu/GNOME at work.

In my Windows setup, the context menu is triggered on the release of the right mouse button; in my Ubuntu/GNOME setup, it's triggered on the press. This is causing me pain because apparently I've developed a habit in Windows of right clicking a bit early, i.e. while still moving the cursor. This has no undesirable side effect in Windows, but in my Ubuntu/GNOME setup, the click immediately brings up the context menu, and the residual movement can sometimes highlight a menu item, and the button release will then act on that selection.

In other words, in Ubuntu/GNOME, where as my intention is just to bring the context menu, I instead accidentally selected some menu item (usually the top most) and execute it. How can I prevent this from happening? Can I make Ubuntu/GNOME bring the context menu on release of right mouse button, the way I'm used to in Windows?


Another habit I've picked up is that I use Alt-F,S to save documents. Now, some editors (e.g. Eclipse) are "smart" in that it knows if a file doesn't need saving, and will disable the Save menu item in that case. Regardless, Alt-F,S would "work" in that it's a no-op (just like Ctrl-S would be). That is, even though Save is disabled, hitting S would still close the File menu, it just wouldn't save the document.

However, in Ubuntu/GNOME, when the Save menu item is disabled in Eclipse, Alt-F,S would get "stuck" on the File menu. Since Save is disabled, S would just not do anything, and the File menu stays open.

I know I can just try to switch to Ctrl-S instead, but can I just configure Ubuntu/GNOME to let me try Alt-F,S even if that particular menu item is disabled? (just ignore the action, just like Windows does).


By the way, I'm open to using another window manager if necessary.

share|improve this question
    
Eclipse isn't a Gtk/GNOME application, and it seems like GNOME applications like gedit don't have this issue, so maybe this is more like an issue with Eclipse instead? –  JanC Nov 7 '10 at 10:02
    
BTW: unlearning habits is often the most difficult part of moving to another platform... ;) –  JanC Nov 7 '10 at 10:04
    
This seems like it should be two separate questions. –  moberley Nov 8 '10 at 2:13
add comment

2 Answers

The first question involves code changes to gnome, as far as I know there is no way to change this behaviour without code changes. you might want to report a bug.

The second question is a problem with Eclipse/Java.

share|improve this answer
add comment

try kde, is more windows-like, gnome is more mac-like

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.