Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

You've heard this a million times but the "tap to click" is a pain in the behind and I want to disable it. There is no touchpad in gpointing-device-settings and neither in mouse and touchpad in system settings. I've tried some commands in terminal but it's all crap. Dconf-editor doesn't react. How about solving this once and for all?

Comp: Dell inspiron N5110

xinput list:

⎡ Virtual core pointer                      id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ PS/2 Generic Mouse                        id=13   [slave  pointer  (2)]
⎣ Virtual core keyboard                     id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ Video Bus                                 id=7    [slave  keyboard (3)]
    ↳ Video Bus                                 id=8    [slave  keyboard (3)]
    ↳ Power Button                              id=9    [slave  keyboard (3)]
    ↳ Sleep Button                              id=10   [slave  keyboard (3)]
    ↳ Laptop_Integrated_Webcam_HD               id=11   [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=12   [slave  keyboard (3)]
    ↳ Dell WMI hotkeys                          id=14   [slave  keyboard (3)]

EDIT:

I think someone fixed it here on launchpad

Can someone explain the fix like I was a four year old idiot? (using precise pangolin)

share|improve this question
    
I have a little script that works for me and probably works for you. I will post it for you later today when I am home. ;) –  fossilet Apr 5 '12 at 2:12
    
what do you get when you run `xinput list'? Please paste it somewhere all the output. –  fossilet Apr 5 '12 at 14:47
    
Possible duplicate? askubuntu.com/questions/117010/… –  fossfreedom Apr 5 '12 at 22:24
    
Well it's multiplicate because there doesn't seem to be a solution for all. –  AWE Apr 10 '12 at 21:52
    
Can you add the model laptop to your question? Perhaps we can narrow this down a bit. –  Jorge Castro Apr 11 '12 at 4:16

3 Answers 3

This solved all my problems

http://redoem.com/2011/07/04/enable-full-touchpad-functionality-in-ubuntu/

do all of these steps, and you will not have the touchpad problems anymore at all.

share|improve this answer
    
Welcome to Ask Ubuntu! Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. –  RolandiXor Dec 11 '13 at 19:08
    
Nope, nothing happened –  AWE Jan 24 at 14:30

In my Ubuntu 12.04 (for Toshiba AC100), there is such an option in the settings, exactly as shown in the image in http://askubuntu.com/a/85069/19753 .

Perhaps, the required component of the settings menu isn't installed in your system. What can be the explanation otherwise?

Perhaps, that's the problem regarding "the ALPS touchpads which are not recognized by Ubuntu. They behave as a PS2 mouse and the touchpad tab is missing from the mouse menu. Therefore there is no scroll option and, the most annoying thing, while typing, the cursor often jumps because I touch the touchpad. I found a program which can disable the touchpad on command: touchpad-indicator, which was found on the Ubuntu help page. This program seems to be able to stop and start the touchpad on command."

I don't know whether you have such an ALPS touchpad. If so, touchpad-indicator could be of some use to you.

share|improve this answer

Type this into the terminal:

synclient MaxTapTime=0

But it will only work for the session, unfortunately.

I have also found this which I have now tried myself

Essentially it is a way to put the synclient settings MaxTapTime=0 into an executable file (I personally don't like fixes which involve installing GUIs on lubuntu - the whole point of it is lightness.

I have now found that there is a way to get a .sh file to come on at startup in lubuntu see this thread where I asked about it.

If you type

>>synclient 

Into terminal. This will bring up all the possible settings for the touchpad, so you can potentially do more tweaking.

share|improve this answer
2  
I recommend further editing this answer to summarize the basic points of the link you've added. –  Eliah Kagan Jul 21 '12 at 16:54
2  
    
Seems it is possible. I have not tried it myself but +1 for adding the link. –  Magpie Mar 29 '13 at 18:51

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.