Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

At the moment when I print, my Deskjet-3050 is selected as the default printer.

I would like 'Print to File' to be the default 'printer' without using cups-pdf


I specifically do not want to use cups-pdf because of the way it renders text (see below). I am not entirely sure what it is doing but it seems as though it renders the text as bitmaps and embeds them in pdf (as I am not able to highlight/copy/search embedded text as I am using a standard Print to File pdf).

enter image description here

N.B. this is not a dupe of: Can I make PDF the default for 'print to file'

share|improve this question
    
Why specifically not cups-pdf? –  Oli Apr 4 '12 at 15:47
    
@Oli see above for why not cups-pdf –  edm Apr 4 '12 at 17:12
    
What program are you using to view the generated PDF file from cups-pdf? –  William Apr 5 '12 at 2:53
2  
Evince, but it looks just as bad using adobe on windows. Anyway without being rude, this is all beside the point. The question is about setting 'Print to File' as the default and not about using/fixing cups-pdf. –  edm Apr 7 '12 at 15:39
    
In other words, you want to print to a PostScript file? Unfortunately, I do not know how to set this as default, but you can set it each time you print. I might suggest that instead of setting print-to-file as default, you open a question on the Ubuntu Forums to fix the poor rendering of your PDF -- it should not be poor like that. You may be using a non-Truetype font. –  Paddy Landau Apr 8 '12 at 15:02

4 Answers 4

Stop cupsd by running

sudo stop cups

Then edit /etc/cups/printers.conf with your favourite editor.

Find the line that says

<DefaultPrinter somename>

And change it to

<Printer somename>

Then start cupsd with

sudo start cups

And that should remove the default printer thus reverting print to file as the default.

share|improve this answer
1  
Removing that setting from the config file sets no default rather than print to file. –  edm Apr 18 '12 at 20:21

You're probably going to need to print to Ghostscript to arrange everything, then use something like PDFTK to actually get the data that you want merged.

share|improve this answer
    
I can see this as useful, but a bit cumbersome... –  hexafraction May 1 '12 at 17:53
    
Ditto, but it doesn't seem like there's a world of options either. –  ehime May 1 '12 at 18:22

are you sure thats not dependent on the source doc ....its like that for everything ??? that is so weird .... the best way to print is in 2 steps pdfs in my humble opinion should always run through a post script like ghostscript is my fav before being outputted to file ...I mean really whats an extra second if your actually going to need to read the doc

try this it should help you set up the print process
http://www.arsgeek.com/2007/05/17/5-steps-to-create-a-pdf-printer-print-to-pdf-in-ubuntu/

cups is lame i agree

share|improve this answer

According to Matt Cutts, you can also set a variable in your .bashrc

export PRINTER=printer-name

Source: http://www.mattcutts.com/blog/change-default-printer-linux-firefox/

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.