Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm fresher than the prince to Linux, I've been following the instructions here: http://chrisfulstow.com/running-node-js-on-windows-with-virtualbox-and-ubuntu (the link tells what I am generally trying to do).

I'm all up and running in VBox, and am at the curl install part, I may have done the curl part a week ago I forget. So I ran this command anyway:

danjah@danjah-VirtualBox:~$ sudo apt-get install curl

Result:

[sudo] password for danjah: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
curl is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

Then:

$ curl http://npmjs.org/install.sh | sudo npm_install=rc sh

Result:

fetching: {

gzip: stdin: unexpected end of file
/bin/tar: Child returned status 1
/bin/tar: Error is not recoverable: exiting now
It failed

Should I be concerned? How can I test curl? How can I avoid these situations? Perhaps there's a generic way of checking to see if I've already installed packages/etc?

Case specific answers and general advice most appreciated.

cheers, d

share|improve this question
    
I doubt that anything went wrong with your curl install, the fetching: { message comes from the install script curl downloaded for you. In general, if you need to know if a package is installed: dpkg-query -s curl (or whatever package), and look at the line that starts with Status: –  taneli Apr 4 '12 at 12:30

1 Answer 1

What version of Ubuntu are you using? Because 11.10 (and 12.04) have node package manager in the repositories so it can be installed through the software centre or by

sudo apt-get install npm

p.s. If you posted on the forums people would be able to walk you through exactly what you are trying to do.

share|improve this answer
    
thanks for the prompt reply - Ubuntu 11.10, yes, and i have npm as I have installed 'connect', 'express' and 'yui3' via npm successfully. I ran the cmd provided anyway, and it has processed and installed npm (again?). No errors, until I try the 'curl npmjs.org/install.sh | sudo npm_install=rc sh'. You're right I should probably move this to ubuntu forums... I kind of like stackexchange though ;) –  Danjah Apr 4 '12 at 11:04

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.