Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying to configure my wifi card in Ubuntu 10.10 server (no GUI, therefore no NetworkManager). I've found a bunch of similar questions here, but none that quite match my problem.

My card is recognised; running "iwconfig wlan0" gives something like this:

wlan0     IEEE 802.11g  ESSID:"networkname"  
  Mode:Managed  Frequency:2.437 GHz  Access Point: Not-Associated   
  Bit Rate:54 Mb/s   Tx-Power:20 dBm   Sensitivity=-121 dBm  
  RTS thr=2347 B   Fragment thr=2346 B   
  Power Management:off

And I can see my wifi network's SSID with "iwlist scan", so the card is definitely working on some level. I've tried following the Ubuntu docs, specifically running:

iwconfig wlan0 mode managed
iwconfig wlan0 channel 4
iwconfig wlan0 essid networkname

But this hasn't associated the network with an access point. I've also tried the command "iwconfig wlan0 key s:mypassphrase", but this is is rejected with "Invalid argument" -- do I need to enter the hex form of the key rather than the passphrase? Or am I missing something else entirely?

share|improve this question
add comment

1 Answer

up vote 0 down vote accepted

It turns out that iwconfig was a complete red herring. I instead tried configuring wpa_supplicant, and that did the job. For the benefit of future generations, here's the incantation that I used:

wpa_supplicant -iwlan0 -c/etc/wpa_supplicant.conf

With the following wpa_supplicant.conf file:

ctrl_interface=/var/run/wpa_supplicant

network={
    ssid="SSID"
    key_mgmt=WPA-PSK
    proto=WPA
    psk="passphrase"
}
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.