Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have researched the solution...

gconftool-2 --type string --set /apps/gnome-power-manager/buttons/lid_ac "nothing"

does not fix it. I have two external monitors and when I close my lid the settings are reset and the laptop's monitor is set to the default.

Thanks!

gsettings list-recursively org.gnome.settings-daemon.plugins.power  
org.gnome.settings-daemon.plugins.power active true  
org.gnome.settings-daemon.plugins.power button-hibernate 'nothing'  
org.gnome.settings-daemon.plugins.power button-power 'nothing'  
org.gnome.settings-daemon.plugins.power button-sleep 'nothing'  
org.gnome.settings-daemon.plugins.power button-suspend 'nothing'  
org.gnome.settings-daemon.plugins.power critical-battery-action 'suspend'  
org.gnome.settings-daemon.plugins.power idle-brightness 30  
org.gnome.settings-daemon.plugins.power idle-dim-ac false  
org.gnome.settings-daemon.plugins.power idle-dim-battery true  
org.gnome.settings-daemon.plugins.power idle-dim-time 10  
org.gnome.settings-daemon.plugins.power lid-close-ac-action 'nothing'  
org.gnome.settings-daemon.plugins.power lid-close-battery-action 'nothing'  
org.gnome.settings-daemon.plugins.power notify-perhaps-recall true  
org.gnome.settings-daemon.plugins.power percentage-action 2  
org.gnome.settings-daemon.plugins.power percentage-critical 3  
org.gnome.settings-daemon.plugins.power percentage-low 10  
org.gnome.settings-daemon.plugins.power priority 1  
org.gnome.settings-daemon.plugins.power sleep-display-ac 600  
org.gnome.settings-daemon.plugins.power sleep-display-battery 600  
org.gnome.settings-daemon.plugins.power sleep-inactive-ac false  
org.gnome.settings-daemon.plugins.power sleep-inactive-ac-timeout 0  
org.gnome.settings-daemon.plugins.power sleep-inactive-ac-type 'suspend'   
org.gnome.settings-daemon.plugins.power sleep-inactive-battery true  
org.gnome.settings-daemon.plugins.power sleep-inactive-battery-timeout 0  
org.gnome.settings-daemon.plugins.power sleep-inactive-battery-type 'suspend'  
org.gnome.settings-daemon.plugins.power time-action 120  
org.gnome.settings-daemon.plugins.power time-critical 300  
org.gnome.settings-daemon.plugins.power time-low 1200  
org.gnome.settings-daemon.plugins.power use-time-for-policy true  
share|improve this question

1 Answer 1

In Ubuntu 11.10 these should force your lid close action to nothing.

gsettings set org.gnome.settings-daemon.plugins.power active 'true'
gsettings set org.gnome.settings-daemon.plugins.power lid-close-ac-action 'nothing'

(optional)

gsettings set org.gnome.settings-daemon.plugins.power battery-action 'nothing'

The first one will make sure that GNOME's power daemon is taking care of the power settings and not some other process.

The second will define the close lid action to nothing when the laptop is plugged in to the power supply and the optional 3rd the same but in case you are running on battery.


Further available options and tools

Use this command in a terminal to have a look at all the available power options

gsettings list-recursively org.gnome.settings-daemon.plugins.power

this will list all the options and their current set values. To set them up to a different value use the command

gsettings set schema [:path] key value

For more information on the gsettings tool check the man page.

Optionally you can install the dconf-tools package and use the dconf-editor tool for graphically checking and changing those options.

enter image description here

Install it via the Ubuntu Software Center (dconf-tools Install dconf-tools) or via a terminal with sudo apt-get install dconf-tools.

share|improve this answer
    
Alright I followed that exactly. Everything checks out. I restarted my computer even and I still am running into the same problem. Its driving me crazy. –  John Lanz Apr 3 '12 at 20:17
    
Try changing button-sleep and button-suspend also to nothing, some laptops might get close-lid with those actions. No need to restart, changes should be automatic. –  Bruno Pereira Apr 3 '12 at 20:19
    
Yup did that too... I don't know whats up. I miss the old Ubuntu. –  John Lanz Apr 3 '12 at 20:28
    
Add the output of gsettings list-recursively org.gnome.settings-daemon.plugins.power to your question please. –  Bruno Pereira Apr 3 '12 at 20:32
    
It's up there now. –  John Lanz Apr 3 '12 at 20:43

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.