Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've been trying to use Scheduled Tasks and mplayer as an alarm clock, scheduling mplayer /path/to/file.mp3 for my morning wakeup time, but whenever it reaches the scheduled time, mplayer freezes only a few seconds into the MP3. System Monitor indicates that it's still running and taking up most of a CPU core, it's just not playing audio.

The weird thing is that when I select "Run selected task," it goes just fine. (And in a terminal, which might be related.) It just doesn't work when it's running as a scheduled thing, whether it's as a recurring or one-time task. So it has to have something to do with the scheduler itself, and I don't know much about cron. What gives?

share|improve this question
1  
Is this because mplayer is quite verbose with it's output? Try commanding it to be quiet, or redirecting it's output to /dev/null –  Adrian Apr 3 '12 at 17:39
    
That appears to have done the trick, though I'm still not sure why that caused a problem. Thanks! –  Shay Guy Apr 4 '12 at 2:05
add comment

1 Answer

The reading of key events from standard input seems to cause this, add following options:

-noconsolecontrols -really-quiet
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.