Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've installed Ubuntu 11.10 on a new Lenovo Thinkpad 420s and I'm trying to get some VirtualBox VMs up and running (using Vagrant). Everything works fine until I try to add host-only networking. This is the failure I get in the terminal:

host-only networking failure - terminal

I set logging to debug and tried again. Here's a paste of the relevant portion of the log.

When I try to add host-only networks with the VirtualBox gui (File->Preferences->Networking->Add host-only networking), I get the following error message:

VirtualBox gui host-only networking failure

This error is occurring with three different virtual boxes, all Ubuntu 11.10 64bit guests, one of which I've run without issue on a Windows host and an OSX host.

Here is the Vagrantfile for the box I've successfully run on Windows and OSX:

Vagrant::Config.run do |config|
  config.vm.box = "ubuntu-11.10"
  config.vm.box_url = "http://timhuegdon.com/vagrant-boxes/ubuntu-11.10.box"
  config.vm.network :hostonly, "192.168.33.10"
  config.vm.customize ["modifyvm", :id, "--memory", "512"]
  config.vm.customize ["modifyvm", :id, "--natnet1", "10.0.28.0/24"]
  config.vm.forward_port 80, 4567
end

I've tried two other boxes as well, one of which I built last night with veewee, all of which are getting the exact same error.

I've used rvm to install ruby 1.9.3-p125 [ x86_64 ], and I've got Vagrant running in its own gemset.

I've Googled quite a lot and haven't been able to find any resolution. Suggestions?

share|improve this question
add comment

1 Answer 1

up vote 2 down vote accepted

It's a known bug of VirtualBox 4.1.12 (from the VBox apt repository).

I've removed VBox and then manually installed the previous version 4.1.10 and now everything works again.

share|improve this answer
1  
Confirmed, it's a regression in 4.1.12, bugreport: virtualbox.org/ticket/10405, forum link: forums.virtualbox.org/viewtopic.php?f=1&t=48854#p222052 –  Javier Rivera Apr 4 '12 at 11:14
    
Seems like they have released a fix, but they haven't bumped the version number. Not a very good idea for package managers... deleting cache and reinstalling could work. –  Javier Rivera Apr 4 '12 at 11:15
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.