Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have two HDD on my ubuntu machine. One is a maxtor 320Gb and the other is a verbatim 1.5Tb. While it automatically recognizes the first one as sdb1 it doesn't recognize the latter. I can't see it on fdisk either.

How can I fix this?

Edit: Forgot to mention that is an USB with NTFS filesystem.

share|improve this question
    
Does it have a filesystem on it? –  Nick Pascucci Nov 7 '10 at 0:38
    
What interface does it use? USB, eSATA? When attaching it, does it appear in the dmesg output? –  Kees Cook Nov 7 '10 at 0:39
    
@Kees It doesn't appear in the dmesg output. –  Mark Nov 7 '10 at 0:43
    
If it doesn't appear in /dev/ or dmesg, it may be a hardware issue. Check the connections, and make sure everything's all right... –  Nick Pascucci Nov 7 '10 at 0:55
    
Works fine on windows. I don't know what the issue is, I tried all USB ports. The USB ports all work. My mouse is on USB as well. –  Mark Nov 7 '10 at 0:57
show 2 more comments

3 Answers 3

try fdisk -l and then fdisk -l /dev/sdx to make sure you know which device it is, not much you can do if it turns out it really isn't showing up in /dev/ try a different usb port?

share|improve this answer
add comment

Post the output of dmesg

Can you mount your secondary harddisk manually.

Try to mount manually,let me know if it solves your problem

sudo mkdir /mnt/test && sudo mount /dev/sdb1 /mnt/test

share|improve this answer
add comment

Is it a single 1.5 TB partition? PLease post the output of dmesg as only then can anyone here help you.

sometimes you have to force a mount because ubuntu wont mount unclean ntfs filesystem

sudo mount -t ntfs-3g /dev/sdb1 /mnt/test -o force

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.