Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Yesterday I tried to Upgrade from kernel 3.0.17 to 3.0.18. After reboot, instead of log in screen I landed on a black screen called busybox it said something like /bin/bash not found, initrams.

I have Ubuntu 11.10 (kernel version 3.0.17). Any help to understand what I did wrong or what the bug is.

share|improve this question
    
not sure this is a real question...works for me –  hbdgaf Apr 3 '12 at 7:43
    
what does that mean ? you don't understand the question, or you don't have a answer because your update worked perfect for you? –  david Apr 3 '12 at 8:50
    
So boot with 3.0.17 instead? –  psusi Apr 3 '12 at 17:41
    
right, that's what I have done but I was wondering what caused this to happen so i can fix it without reverting to 3.0.17 at grub when I need to restart my computer. no big deal really, just curious. –  david Apr 3 '12 at 20:27
    
hmm, sounds interesting on the second guess. I wonder why updm would figure i need busybox for the 3.0.18 version unless it is dumping grub and replacing it with busybox because that is what it is supposed to be doing and failed to update properly for it to do so. if so , how do i dump 3.0.18 so i can reinstall it. thanks –  david Apr 4 '12 at 1:31
add comment

closed as too localized by Luis Alvarado Apr 7 '13 at 16:01

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

1 Answer

In a normal out of the box install, if you get to a black screen and grub fails to find /boot, it drops to the grub prompt not busybox.

If it finds /boot, then it boots properly.

The only things I can think of is that would get you in this kind of inconsistent state are:
1) interrupting the grub update by powering off
2) installing busybox as a boot option.

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.