Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Firefox 11 doesn't show any text on some sites as Google and Youtube. Also Lotus Symphony doesn't show many UI Labels. This problem occurred suddenly.

Firefox display error: enter image description here


Symphony display error: enter image description here

share|improve this question

3 Answers 3

Take a look under the Firefox Preferences -> Content and see what Default Font is set there, like in the screenshot. enter image description here

Now see if you have that font installed in Ubuntu System. If not (which i think is not the case, since common applications in general use common fonts, that come with the installation) either install it afterwards, or use another font as default in Firefox.

Also you might want to take a look under the Advanced-Button -> Default Character Encoding and make adjustments there! To me it seems, that your Encoding is wrong which is the problem if not mistaken!

If that still does not resolve your problem, please edit your post and add a screenshot and/or more information about your settings that you use in FF. enter image description here

share|improve this answer

It seems that you have a problem with your system's fonts. Try reinstalling the font. You can see a guide to this here.

You can also try this:

sudo apt-get install msttcorefonts
sudo fc-cache -fv

This post seems very similar to yours (I would say is duplicated).

Best regards,

share|improve this answer

This is a problem with your fonts. I had this problem on different machines.

To solve it I had to set the appropriate rights of the fonts and regenerate the font cache. You can use the following script to fix the display of fonts in Firefox.

Change yourname in the MY_USER variable to the appropriate username.

 #!/bin/bash
MY_USER="yourname"

# set rights of the font system folders
chmod -R 755 /usr/share/fonts
chmod -R 755 /usr/local/share/fonts 
chmod -R 755 /etc/fonts

# Recreate font cache
fc-cache -rv


# Change user font cache
# set rights
chown -R "$MYUSER":"$MYUSER" "/home/$MYUSER/.fontconfig"
chmod -R 755 "/home/$MYUSER/.fontconfig"

# rebuild cache
su $MYUSER -lc "fc-cache -rv"
share|improve this answer
    
I had this same issue with Firefox 20.0 and Ubuntu 12.10 (dual-boot with Windows 7). I had copied several MS fonts from the Windows partition to /usr/share/fonts/ and run sudo fc-cache -f -v, only to have Firefox end up with completely blank pages. Turned out that the fonts I'd copied in were set to 600 instead of 644 or 755. –  Pat J Jun 19 '13 at 16:01

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.