Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

As you can see, mysql exists only in the /etc/init.d directory and not in /etc/rcN.d, therefore it shouldn't start on boot.

$ sudo find /etc -regex ".*\(rc.*d\|init\.d\).*" | sudo grep "mysql" | sort
/etc/init.d/mysql
share|improve this question
add comment

1 Answer 1

up vote 7 down vote accepted

MySQL is started by upstart. You can find the configuration file at /etc/init/mysql.conf

share|improve this answer
    
Thanks. I've edit that file and replaced the line ` and runlevel [2345])` with ` and runlevel [345])`. –  Dor Nov 6 '10 at 22:09
    
You can also be more clear and say 'start on never' –  SpamapS Nov 9 '10 at 6:06
    
New versions of Ubuntu use upstart(upstart.ubuntu.com) to manage service (start/stop/restart etc). It's a good system but I'm unable to disable a service to start on Ubuntu startup. I think that edit the configuration file as advised by txwikinger isn't a good method, so how to proceed? –  neuromancer Nov 9 '10 at 9:34
    
Unfortunately, currently this might be the only method. Maybe we need some better way to allow packaged configuration being mixed with local additions for upstart. –  txwikinger Nov 10 '10 at 0:32
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.