Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After last weeks flash update Hulu desktop no longer works on my Dell laptop though it still works on my HP Desktop. Here's what CLI tells me on the Dell:

Inspiron-1564:~$ huludesktop
Failed to open VDPAU backend libvdpau_nvidia.so: cannot open shared object file: No such file or directory

I tried: sudo apt-get install libvdpau_nvidia.so but got E: Unable to locate package libvdpau_nvidia.so and E: Couldn't find any package by regex 'libvdpau_nvidia.so'

Hulu does work through the browser and through XBMC. XBMC just doesn't seem to match the video quality of the Hulu Desktop.

I don't really know why a nvidia.so is needed for my Intel graphics that comes on Dell Insiron 1564's. anyway. So, do you guys have a solution?

share|improve this question
    
possibly this package - libvdpau1 either needs installing or removing - can you try? –  fossfreedom Apr 11 '12 at 22:41
    
... also double check that you havent accidently installed any nvidia drivers i.e. sudo apt-get -s remove nvidia-* N.B. this will simulate NOT remove anything - please pastebin.com your result. –  fossfreedom Apr 11 '12 at 22:44
    
Ok. I ran that command to remove nvidia drives. It found a couple but I had to run sudo apt-get remove for them to actually be removed. They were nvidia-common and vdpau-va-driver. Then I deleted the "dummy" file and symbolic link suggested by Daniel. WITH libvdpau1 installed huludesktop outputs: Failed to open VDPAU backend libvdpau_nvidia.so: cannot open shared object file: No such file. WITHOUT libvdpau1 the output is just a blinking cursor. –  jwdinkc Apr 12 '12 at 15:46
    
I forgot to mention, even though the terminal just goes to the next line with a blinking cursor after inputting huludesktop,the window opens and is correctly labeled and themed but there are no contents to the window. Just black. –  jwdinkc Apr 12 '12 at 15:59
    
... that is why I asked you to simulate a removal - the nvidia-common should actually be installed by default (i'm using an intel graphics chipset, and nvidia-common is also installed). however i wasnt expecting vdpau-va-driver but I doubt this would cause your issue. –  fossfreedom Apr 12 '12 at 20:32

5 Answers 5

up vote 1 down vote accepted

The issue is with the most recent releases of Flash into the repos. The solution that worked for me was to download a previous version of Flash from Adobe's archived versions, in particular 11.1.102.62:

http://fpdownload.macromedia.com/get/flashplayer/installers/archive/fp_11.1.102.62_archive.zip

Found here:

http://helpx.adobe.com/flash-player/kb/archived-flash-player-versions.html

Simply extract and drill down until you find your distro (for me 11_1r102_62_64bit/flashplayer11_1r102_62_linux.x86_64) and copy the libflashplayer.so to /usr/lib/mozilla/plugins and then point Hulu there in ~.huludesktop.

flash_location = /usr/lib/mozilla/plugins/libflashplayer.so

Good luck and Good watching!

share|improve this answer
    
Thanks. I'm going to keep the new flash for everything else but put this older version in my home folder solely for Hulu destop! Good call. –  jwdinkc Apr 27 '12 at 15:39

I don't know why it's not working or why it needs nvida files, but that file can be found in (and installed with) the packages nvidia-current and/or nvidia-current-updates.

share|improve this answer
    
I'm not sure how that would work since my Dell uses Intel HD graphics. Wouldn't there be a conflict or at least a miss-match? –  jwdinkc Apr 11 '12 at 15:19
    
I'm sorry, I don't really know it :) –  dadexix86 Apr 11 '12 at 20:24
    
Thanks for the attempt but I'm not comfortable adding Nvidia drivers to my Intel system unless it's confirmed not to be an issue. –  jwdinkc Apr 11 '12 at 22:29
    
You're right in that the nvidia package provides vpdau and it was originally a proprietary technology only used by nvidia. There are abstraction layers now though. I know this to be true for ATI. I'm not sure on intel. –  hbdgaf Apr 16 '12 at 13:56
    
It doesn't work with livdpau1 or without but with it I at least get an error message. –  jwdinkc Apr 16 '12 at 21:42

Try installing these two packages: vdpau-va-driver,libvdpau1 to install both type

sudo apt-get install vdpau-va-driver libvdpau1

chances are the file that is missing is included in libvdpau1. You might need to restart the computer in order for the changes to take effect.
Maybe this method is more elegant than the above mentioned because installing nvidia drivers is likely to mess up your existing ones.

For some info on what VDPAU is and does see this: http://en.wikipedia.org/wiki/VDPAU

share|improve this answer
    
Same error after install. –  jwdinkc Apr 11 '12 at 15:16
    
try to make a dummy file by typing: sudo touch /usr/lib/libvdpau_nvidia.so and if you are running an 64bit system also: ln -s /usr/lib/libvdpau_nvidia.so /usr/lib32 This put's an empty file with the name of the missing librabry into /usr/lib and a link to it in the /usr/lib32 directory. This might help if the programm is just trying to check whether or not the file is there regardess if you need it or not. –  Daniel Apr 11 '12 at 18:50
    
Ok. I installed the vdpau-va-driver and libvdpau1, created the dummy file and symbolic link as mentioned above. Here's the output now: Failed to open VDPAU backend /usr/lib/libvdpau_nvidia.so: file too short –  jwdinkc Apr 11 '12 at 19:29

Have you tried removing hulu and reinstalling? sudo apt-get purge huludesktop and then reinstall? Worth a shot anyways.

share|improve this answer
    
Yeah. I've done this multiple times. Including deleting the home/.huludestkop file. –  jwdinkc Apr 17 '12 at 15:46

You can disable hardware acceleration. It's detailed here and here.

share|improve this answer
    
Done. I use better privacy so I had to "protect" the settings LSO through the add-on. But I verified that the configurations were saved. –  jwdinkc Apr 16 '12 at 21:45
    
Does it still throw the error? Reports on Ubuntuforums indicated that solved it for them. –  hbdgaf Apr 16 '12 at 21:58
    
It doesn't throw the error(just goes to a blinking cursor on the next line) when libvdpau1 is not installed. It does throw the error when it is. Currently it is not. Disabling hardware acceleration didn't change this dynamic. –  jwdinkc Apr 17 '12 at 15:49

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.