Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I started my laptop one day and I got a warning message before the login screen saying (Use/lib/libconf2-4/gconf-sanity-check-2 exited with status 256).

Trust me, I checked Google and all Ubuntu forums to find the answer to this before posting my issue here.

I found that many people have had the same issue but none of their sulutions worked for me.

mostly cause:

  1. I can't login using gnome so I have to use the command line.

  2. Everytime I sudo I get something about soduers mode not being 0440 (when I looked that up and tried to change the mode as some forums suggested, I got an error saying permission denied.)

  3. I tried to 'su to root' to fix that but then i get something about authentication being wrong!

So it looks quite shut from everywhere and I am REALLY lost.

I dont mind reinstalling Ubuntu and having all data erased, I already have everything saved on a hard drive, but when I put in the Ubuntu Install CD, it ejects it before booting from it and refuses to boot from any other CD as well.

Please help me out I have been trying for 3 weeks now and this is honestly my last resort .

Thank you so much in advance.

I love Ubuntu and I want it back.

share|improve this question
    
This sounds like something happened to your gconf data, you can try to let him restore the default settings by moving the folder. Log in on the terminal and execute the following command mv .gconf .gconf_backup and then try to login again via GDM. –  Bobby Nov 6 '10 at 20:55
    
ThanK you I will give it a try Now . –  Walid Al Wawi Nov 6 '10 at 20:58
    
Nothing happend honestly, it still refuses to log in from the GDM ! –  Walid Al Wawi Nov 6 '10 at 21:15
    
Can you login using the command line and then run startx? –  Nathan Osman Nov 6 '10 at 21:33
3  
Judging from the sudoers file permissions change and the other random issues, it is likely that you have done a recursive permissions chnage (chmod -R something / ). Your best solution on this case is really the reinstall. –  João Pinto Nov 6 '10 at 21:41
show 4 more comments

1 Answer 1

You might want to check your BIOS settings if you can't boot from a CD. Also, you might want to try burning another Ubuntu CD.

share|improve this answer
    
So greatful for the fast reply. I am using a macbook and i Have tried the Ubuntu Cd on many Other laptops and always worked perfectly, Also the apple OSX Cd isn't booting as well, So I am quite sure the issue isn't with the CD. –  Walid Al Wawi Nov 6 '10 at 20:54
    
I suppose you already know that, but I seem to remember something about needing to hold down some key while booting from CD on a Mac...? –  JanC Nov 7 '10 at 2:01
    
I guess this might be useful. –  JanC Nov 7 '10 at 2:04
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.