Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have installed Ubuntu 12.04. I am unable to play proprietary media formats on Ubuntu Precise even after installing Ubuntu-Restricted-Extras. I am using Totem and Rhytmbox as my players.

share|improve this question
    
Can you try playing a file, and explain exactly what happens. Post any errors there are, and if you aren't able to do some or any of that, perhaps explain why not. –  mikewhatever Apr 2 '12 at 9:23
1  
even after installing the restricted extra there are some particular formats which are not played... by the way which are the ones you are facing problem with? Try using VLC for video formats.. –  abhishek Apr 2 '12 at 9:36
1  
The term "proprietary media formats" covers a lot of things. Could you be more specific? Seeing Totem, Rhythmbox and VLC makes me think: commercial DVDs. The surest thing for this is to add the Medibuntu Repository (medibuntu.org/repository.php) and get the package libdvdcss2 from there. –  arochester Apr 2 '12 at 10:25
    
I an trying to play a mp4 file in totem player and it is simply not playing. Totem is executing but the video is not playing. No warning or message is coming. I tried the same with other video files, but same result. –  Vikramjeet Apr 2 '12 at 11:43

2 Answers 2

up vote 1 down vote accepted

Install gstreamer0.10-ffmpeg and it should play fine.

share|improve this answer
    
Its installed with Ubuntu Restricted Extras. –  Vikramjeet Apr 2 '12 at 12:28
    
Do you have gstreamer0.10-plugins-good installed? –  dobey Apr 2 '12 at 14:11
    
Yes I also did sudo apt-get -f install. It showed zero changes. –  Vikramjeet Apr 2 '12 at 15:07
    
OK. They play fine here. Perhaps you are hitting some bug then and should open a bug report by running "ubuntu-bug totem" in a terminal for example. I don't think there's any simple answer to be had on askUbuntu at this point. –  dobey Apr 2 '12 at 16:28

this code fixed the issue for me:

sudo apt-get install gstreamer0.10-ffmpeg gstreamer0.10-fluendo-mp3 gstreamer0.10-gnonlin gstreamer0.10-sdl gstreamer0.10-plugins-bad-multiverse gstreamer0.10-schroedinger gstreamer0.10-plugins-ugly totem-plugins-extra

source

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.